summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-25 21:37:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-25 21:37:46 +0200
commit15e71b212fbc628bf8f742192b6525f4d87cab6d (patch)
treed54006d8a7d86e0c1d695399d98fdb16eade3127 /net-libs
parentnet-libs/telepathy-qt: update EAPI 7 -> 8, enable py3.11 (diff)
downloadgentoo-15e71b212fbc628bf8f742192b6525f4d87cab6d.tar.gz
gentoo-15e71b212fbc628bf8f742192b6525f4d87cab6d.tar.bz2
gentoo-15e71b212fbc628bf8f742192b6525f4d87cab6d.zip
net-libs/telepathy-qt: Fix building tests with newer glib
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt/files/telepathy-qt-0.9.8-fix-tests-finding-glib-2.patch23
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.8-r2.ebuild (renamed from net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild)7
2 files changed, 27 insertions, 3 deletions
diff --git a/net-libs/telepathy-qt/files/telepathy-qt-0.9.8-fix-tests-finding-glib-2.patch b/net-libs/telepathy-qt/files/telepathy-qt-0.9.8-fix-tests-finding-glib-2.patch
new file mode 100644
index 000000000000..0ac61c48a87a
--- /dev/null
+++ b/net-libs/telepathy-qt/files/telepathy-qt-0.9.8-fix-tests-finding-glib-2.patch
@@ -0,0 +1,23 @@
+From 188dece432d090809c5ad88a91cd573c5af61c09 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Mon, 6 Jun 2022 09:44:53 +0200
+Subject: [PATCH] Fix build with newer glib
+
+gunixconnection.h is now at /usr/include/glib-2.0/gio/gunixconnection.h
+---
+ cmake/modules/FindGIOUnix.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/FindGIOUnix.cmake b/cmake/modules/FindGIOUnix.cmake
+index 263c093e..7f5513b3 100644
+--- a/cmake/modules/FindGIOUnix.cmake
++++ b/cmake/modules/FindGIOUnix.cmake
+@@ -21,7 +21,7 @@ pkg_check_modules(PC_LibGIOUnix gio-unix-2.0)
+ find_path(GIOUNIX_MAIN_INCLUDE_DIR
+ NAMES gio/gunixconnection.h
+ HINTS ${PC_LibGIOUnix_INCLUDEDIR}
+- PATH_SUFFIXES gio-unix-2.0)
++ PATH_SUFFIXES gio-unix-2.0 glib-2.0)
+
+ set(GIOUNIX_INCLUDE_DIR "${GIOUNIX_MAIN_INCLUDE_DIR}")
+
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.8-r2.ebuild
index af50e027063c..89e203b7332d 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.8-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="xml(+)"
inherit python-any-r1 cmake virtualx
@@ -17,7 +17,6 @@ KEYWORDS="amd64 ~arm arm64 ~riscv x86"
IUSE="debug farstream test"
REQUIRED_USE="test? ( farstream )"
-
RESTRICT="!test? ( test )"
RDEPEND="
@@ -47,6 +46,8 @@ BDEPEND="${PYTHON_DEPS}
)
"
+PATCHES=( "${FILESDIR}/${P}-fix-tests-finding-glib-2.patch" )
+
python_check_deps() {
use test || return 0
python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"