summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-21 21:00:37 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-21 22:09:11 +0200
commit2080a4c05f9ab374d8f2303ecdff293ac666f1ab (patch)
treedab415ba326a69050b85c18bd36fd1a4f260d0ba /net-libs
parentmedia-libs/gmmlib: bump to 20.3.2 (diff)
downloadgentoo-2080a4c05f9ab374d8f2303ecdff293ac666f1ab.tar.gz
gentoo-2080a4c05f9ab374d8f2303ecdff293ac666f1ab.tar.bz2
gentoo-2080a4c05f9ab374d8f2303ecdff293ac666f1ab.zip
net-libs/libhtp: bump to 0.5.34
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libhtp/Manifest1
-rw-r--r--net-libs/libhtp/libhtp-0.5.34.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libhtp/Manifest b/net-libs/libhtp/Manifest
index dc1cec7db0f7..0d99c9aa51bb 100644
--- a/net-libs/libhtp/Manifest
+++ b/net-libs/libhtp/Manifest
@@ -1 +1,2 @@
DIST libhtp-0.5.33.tar.gz 496010 BLAKE2B 9648632e9f37c20a3efa5edf9b5ee5ed97b5ba767faf6b276c4d38760422b601f9443cfaf30e60c6e6dd555d259a3b5613f0370040753d7336f6ef5e94b32d55 SHA512 52bbb72710fd0f5fc917d62f5a2b659092669eda0553586e75c17c558e3f6559dcf8eb7707db931045af532592cbad691461af2dd5362f95e2a4884e7475bf94
+DIST libhtp-0.5.34.tar.gz 496765 BLAKE2B 8f4eb6b074d9a84fa872ff963f20b4a52f86d171a03fe2347affa9b9383d0d4ba4633b03ec5ca2a9a923c28d16e3f2304f0b4e32c8c4385c0333ba2f280ad21a SHA512 dc86c6b3a90439e9e2d5375b64119d80771e2dc076670f49b9d5f252d7b16fe5b643a16577ce50189c289e7baf16fcb84d86254d965a11ab1d148ad59455c20f
diff --git a/net-libs/libhtp/libhtp-0.5.34.ebuild b/net-libs/libhtp/libhtp-0.5.34.ebuild
new file mode 100644
index 000000000000..4c0e8229142d
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.34.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+ fi
+}