summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-07-08 18:39:56 +0000
committerSam James <sam@gentoo.org>2023-07-09 03:10:18 +0100
commit484780bbcbc5bbace9eebb4ed538760df7dd2343 (patch)
treeda7c2f1a5dd3e8bef52c9a7c8b1371c159a9f6ce /net-libs
parentsys-devel/automake: Change app-arch/gzip dep to app-alternatives/gzip (diff)
downloadgentoo-484780bbcbc5bbace9eebb4ed538760df7dd2343.tar.gz
gentoo-484780bbcbc5bbace9eebb4ed538760df7dd2343.tar.bz2
gentoo-484780bbcbc5bbace9eebb4ed538760df7dd2343.zip
net-libs/udns: Fix detection of inet_pton and inet_ntop with clang 16
Closes: https://bugs.gentoo.org/883285 Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/31806 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch22
-rw-r--r--net-libs/udns/udns-0.4-r2.ebuild (renamed from net-libs/udns/udns-0.4-r1.ebuild)3
2 files changed, 24 insertions, 1 deletions
diff --git a/net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch b/net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch
new file mode 100644
index 000000000000..5eb0010092a8
--- /dev/null
+++ b/net-libs/udns/files/udns-0.4-configure-pton-ntop-clang16.patch
@@ -0,0 +1,22 @@
+Bug: https://bugs.gentoo.org/883285
+
+From e39b749619191226ccbf8730084c0d2dcadc9065 Mon Sep 17 00:00:00 2001
+From: Violet Purcell <vimproved@inventati.org>
+Date: Sat, 8 Jul 2023 18:34:11 +0000
+Subject: [PATCH] Fix detection of dns_pton and dns_ntop with clang 16
+
+--- a/configure
++++ b/configure
+@@ -94,7 +94,8 @@ int main() {
+ char buf[64];
+ long x = 0;
+ inet_pton(AF_INET, &x, buf);
+- return inet_ntop(AF_INET, &x, buf, sizeof(buf));
++ inet_ntop(AF_INET, &x, buf, sizeof(buf));
++ return 0;
+ }
+ EOF
+
+--
+2.41.0
+
diff --git a/net-libs/udns/udns-0.4-r1.ebuild b/net-libs/udns/udns-0.4-r2.ebuild
index f8f8c3675854..a963d2ac18b4 100644
--- a/net-libs/udns/udns-0.4-r1.ebuild
+++ b/net-libs/udns/udns-0.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,6 +16,7 @@ IUSE="ipv6 static +tools"
PATCHES=(
"${FILESDIR}"/${PN}-0.4-configure-clang16.patch
+ "${FILESDIR}"/${PN}-0.4-configure-pton-ntop-clang16.patch
)
src_configure() {