summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-06-28 00:03:09 +0300
committerMart Raudsepp <leio@gentoo.org>2020-06-28 00:03:17 +0300
commitb556dbce182a49bb66df6920fc5fcf4a546d6215 (patch)
tree2bd13dbbfaf261422bd9dc07e3e3c75b4733fcc7 /net-libs
parentgnome-extra/nm-applet: bump to 1.18.0 (diff)
downloadgentoo-b556dbce182a49bb66df6920fc5fcf4a546d6215.tar.gz
gentoo-b556dbce182a49bb66df6920fc5fcf4a546d6215.tar.bz2
gentoo-b556dbce182a49bb66df6920fc5fcf4a546d6215.zip
net-libs/libnma: bump to 1.8.30
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnma/Manifest1
-rw-r--r--net-libs/libnma/libnma-1.8.30.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/libnma/Manifest b/net-libs/libnma/Manifest
index 9428f91e9ef8..411e28380aad 100644
--- a/net-libs/libnma/Manifest
+++ b/net-libs/libnma/Manifest
@@ -1 +1,2 @@
DIST libnma-1.8.28.tar.xz 1366584 BLAKE2B 598c2d310844930a5ed8b8d4b8bc0ae91193a8e62bccdb60050cc980cd37d198adf728b98694d9f1cf9f523998b865d9682fd271c88e434ead777ed5b69866b4 SHA512 d3996da3433493149edf0743b7f2280a83db2efc2228f04eddb773bbcb08ea2efcb640f781cb1d0a5cbabd8b25b1c612387682ff5239151d8ce249568e877f5b
+DIST libnma-1.8.30.tar.xz 1386248 BLAKE2B 7021e85595819b0cbd44b8c62087f49a5ecccc4bb230820d9a0159bf33b904df4f5c8021a79822c37d0933bdcde790a44f6d960b7f5f504e7506849aed35d54c SHA512 4d8f93d035fca4252e5c5dafc756ee6bc8f1d302aaeca77c5c0acb5d7f6cd4214224fb48e2706e69084c5a714aafa7837769be17d0642cc29eded9eb175a1107
diff --git a/net-libs/libnma/libnma-1.8.30.ebuild b/net-libs/libnma/libnma-1.8.30.ebuild
new file mode 100644
index 000000000000..dac7e9407e80
--- /dev/null
+++ b/net-libs/libnma/libnma-1.8.30.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="NetworkManager GUI library"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+# pkcs11 default enabled as it's a small dep often already present by libnma users, and it was default enabled as IUSE=+gcr in nm-applet before
+IUSE="gtk-doc +introspection +pkcs11 vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ app-text/iso-codes
+ net-misc/mobile-broadband-provider-info
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.10:3[introspection?]
+ >=net-misc/networkmanager-1.7[introspection?]
+ pkcs11? ( >=app-crypt/gcr-3.14:= )
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+"
+RDEPEND="${DEPEND}
+ !<gnome-extra/nm-applet-1.16.0" # gschema moved to here before nm-applet-1.16.0
+BDEPEND="
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend)
+ net-misc/networkmanager[vala]
+ )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlibnma_gtk4=false
+ $(meson_use pkcs11 gcr)
+ -Dmore_asserts=0
+ -Diso_codes=true
+ -Dmobile_broadband_provider_info=true
+ -Dld_gc=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}