summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-06-05 10:07:35 -0400
committerCraig Andrews <candrews@gentoo.org>2023-06-05 10:15:41 -0400
commitc95731f15c5da4892086d0b3d11b0cef394d2150 (patch)
tree5e72969fe18e4798dee328793680a008561f96fe /net-libs
parentnet-libs/ngtcp2: add 0.16.0 (diff)
downloadgentoo-c95731f15c5da4892086d0b3d11b0cef394d2150.tar.gz
gentoo-c95731f15c5da4892086d0b3d11b0cef394d2150.tar.bz2
gentoo-c95731f15c5da4892086d0b3d11b0cef394d2150.zip
net-libs/nghttp3: add 0.12.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-0.12.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index f474123694de..fbb664e63b09 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1 +1,2 @@
DIST nghttp3-0.11.0.tar.xz 367392 BLAKE2B 908da41e168e83d82de7649051c66866682c58e93e3da6a2f4b85a1765b04ccbb06888df3e9b87b5cd6d1eb51d95af9bbb02955e47fde6194b169bb7ef78f756 SHA512 752adffcd5b8d26ea89e040597474e1b6d91a87a5feda445b637fd17255768e570570c0786984e3eaf36dac94df1f32659d9991d3bbf9a02b060c63aadb708fd
+DIST nghttp3-0.12.0.tar.xz 369576 BLAKE2B 552fab00de7c6d1917ac1b680547aa57e02ae32e6347e9915d743daa217ce2d6d201e3ab8f1cf00072e80f489e8bb7af648d46f9805816923b8e7ccd8319bc44 SHA512 4bfde5506bbd193107cac3f548952ae692934b7b9e5639fa843ee99a7da5ee7ca816880fc5575efd57959770e633cdba1efb4fd60ba39fff043e62a6358f721b
diff --git a/net-libs/nghttp3/nghttp3-0.12.0.ebuild b/net-libs/nghttp3/nghttp3-0.12.0.ebuild
new file mode 100644
index 000000000000..719966f4eab6
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-0.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}