summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2024-07-05 20:36:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-10 10:09:02 +0300
commit228d53133b6a97480b562ca1862a3725fe37e79c (patch)
tree02948a0644022b4ff3be42d8ac6d20081f5f3076 /net-mail/automx2/automx2-2024.2.ebuild
parentx11-misc/x11vnc: fix build on 32bit arches with 64bit time_t (diff)
downloadgentoo-228d53133b6a97480b562ca1862a3725fe37e79c.tar.gz
gentoo-228d53133b6a97480b562ca1862a3725fe37e79c.tar.bz2
gentoo-228d53133b6a97480b562ca1862a3725fe37e79c.zip
net-mail/automx2: add 2024.2
Bump to automx2 version 2024.2 (bugfix & feature release). Signed-off-by: Ralph Seichter <github@seichter.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-mail/automx2/automx2-2024.2.ebuild')
-rw-r--r--net-mail/automx2/automx2-2024.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/automx2/automx2-2024.2.ebuild b/net-mail/automx2/automx2-2024.2.ebuild
new file mode 100644
index 000000000000..598ce69b2d1f
--- /dev/null
+++ b/net-mail/automx2/automx2-2024.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11,12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://rseichter.github.io/automx2/"
+SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="acct-user/automx2
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-setupcfg.patch"
+)
+
+distutils_enable_tests unittest
+
+python_test() {
+ local -x AUTOMX2_CONF="tests/unittest.conf"
+ eunittest tests/
+}
+
+python_install_all() {
+ local DOCS=( "${S}"/docs/*.adoc "${S}"/contrib/*sample.conf )
+ local HTML_DOCS=( "${S}"/docs/*.{html,svg} )
+ newconfd "${FILESDIR}/confd" "${PN}"
+ newinitd "${FILESDIR}/init-r1" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}