summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/ripmime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/ripmime')
-rw-r--r--net-mail/ripmime/Manifest1
-rw-r--r--net-mail/ripmime/files/ripmime-1.4.0.9-buffer-overflow.patch11
-rw-r--r--net-mail/ripmime/files/ripmime-1.4.0.9-makefile.patch79
-rw-r--r--net-mail/ripmime/metadata.xml5
-rw-r--r--net-mail/ripmime/ripmime-1.4.0.10.ebuild45
5 files changed, 141 insertions, 0 deletions
diff --git a/net-mail/ripmime/Manifest b/net-mail/ripmime/Manifest
new file mode 100644
index 000000000000..c0b4a71d21f3
--- /dev/null
+++ b/net-mail/ripmime/Manifest
@@ -0,0 +1 @@
+DIST ripmime-1.4.0.10.tar.gz 172155 SHA256 bc7ce0c2ebb6007167718ecfb0c64a9d85a8789d5a6e730ed3f60109a7e1f3f7 SHA512 1c2d2180d60a56c70046e95a29925e39d3f76da98cc2fa153b6fc3a8eb0fc5ec5f45524e9f5ae8706a955366a752d25a0a2f560f1d75de3f2733ec31befb83d3 WHIRLPOOL c82f57a2bd44609b8b698ba15a7353adba601aab52237a7c4f220ffd892052e7c1281272f7d2fcb2c16e8544280070ed0810ea346a68cfb7e7a8177d6761a001
diff --git a/net-mail/ripmime/files/ripmime-1.4.0.9-buffer-overflow.patch b/net-mail/ripmime/files/ripmime-1.4.0.9-buffer-overflow.patch
new file mode 100644
index 000000000000..418a204101e9
--- /dev/null
+++ b/net-mail/ripmime/files/ripmime-1.4.0.9-buffer-overflow.patch
@@ -0,0 +1,11 @@
+--- ripmime-1.4.0.9/MIME_headers.c.orig 2010-11-07 12:38:52.994063648 -0800
++++ ripmime-1.4.0.9/MIME_headers.c 2010-11-07 12:39:06.395161970 -0800
+@@ -2239,7 +2239,7 @@
+ {
+ if (MIMEH_DNORMAL) LOGGER_log("%s:%d:MIME_parse_contentlocation:DEBUG: filename = %s\n", FL, p);
+ snprintf(hinfo->name, sizeof(hinfo->name),"%s",p);
+- snprintf(hinfo->filename, sizeof(hinfo->name),"%s",p);
++ snprintf(hinfo->filename, sizeof(hinfo->filename),"%s",p);
+ FNFILTER_filter(hinfo->filename, _MIMEH_FILENAMELEN_MAX);
+ SS_push(&(hinfo->ss_filenames), hinfo->filename, strlen(hinfo->filename));
+
diff --git a/net-mail/ripmime/files/ripmime-1.4.0.9-makefile.patch b/net-mail/ripmime/files/ripmime-1.4.0.9-makefile.patch
new file mode 100644
index 000000000000..856319bf63b7
--- /dev/null
+++ b/net-mail/ripmime/files/ripmime-1.4.0.9-makefile.patch
@@ -0,0 +1,79 @@
+--- ripmime-1.4.0.9.orig/Makefile 2008-11-06 19:33:33.000000000 -0800
++++ ripmime-1.4.0.9/Makefile 2010-11-07 12:53:03.898947384 -0800
+@@ -42,22 +42,22 @@
+ ./generate-buildcodes.sh
+
+ ripOLE/ole.o:
+- ./build_ripOLE
++ $(MAKE) -C ripOLE
+
+ tnef/tnef.o:
+- ./build_tnef
++ $(MAKE) -C tnef
+
+ .c.o:
+- ${CC} ${CFLAGS} $(COMPONENTS) -c $*.c
++ ${CC} ${CFLAGS} -fPIC $(COMPONENTS) -c $*.c
+
+ all: ${OBJ}
+
+
+ solib: ${OFILES} ripmime-api.o
+- gcc --shared -Wl,-soname,libripmime.so.1 ${OFILES} ripmime-api.o -o libripmime.so.1.4.0 -lc
++ ${CC} ${LDFLAGS} --shared -Wl,-soname,libripmime.so.1 ${OFILES} ripmime-api.o -o libripmime.so.1.4.0 -lc
+
+-libripmime: ${OFILES} ripmime-api.o
+- ar ruvs libripmime.a ${OFILES} ripmime-api.o
++libripmime.a: ${OFILES} ripmime-api.o
++ ${AR} ruvs $@ $^
+
+ ripl: ripmime.a
+ ${CC} ${CFLAGS} ripmime.c ripmime.a -o ripmime
+@@ -65,8 +65,10 @@
+ sco: ${OFILES}
+ ${CC} ${CFLAGS} ripmime.c ${OFILES} -o ripmime -lsocket
+
+-ripmime: ${OFILES} ripmime.c buildcodes.h
+- ${CC} ${CFLAGS} $(COMPONENTS) ripmime.c ${OFILES} -o ripmime ${LIBS}
++ripmime: ${OFILES} ripmime.o
++ ${CC} ${CFLAGS} $(COMPONENTS) $(LDFLAGS) $^ -o $@ ${LIBS}
++
++ripmime.o: buildcodes.h
+
+ riptest: ${OFILES}
+ ${CC} ${CFLAGS} riptest.c ${OFILES} -o riptest
+--- ripmime-1.4.0.9.orig/ripOLE/Makefile 2008-10-31 09:17:32.000000000 -0700
++++ ripmime-1.4.0.9/ripOLE/Makefile 2010-11-07 12:55:38.222278266 -0800
+@@ -4,7 +4,7 @@
+
+
+ .c.o:
+- $(CC) $(CFLAGS) $(DEFINES) -c $*.c
++ $(CC) $(CFLAGS) -fPIC $(DEFINES) -c $*.c
+
+ default: ripole
+
+@@ -12,7 +12,7 @@
+ rm -f *.o ripole
+
+ ripole: $(OBJS) ripole.[ch]
+- $(CC) $(CFLAGS) $(OBJS) $(DEFINES) ripole.c -o ripole
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(DEFINES) ripole.c -o ripole
+
+ validate: ripole
+ cp ripole validate
+--- ripmime-1.4.0.9.orig/tnef/Makefile 2008-11-06 19:33:33.000000000 -0800
++++ ripmime-1.4.0.9/tnef/Makefile 2010-11-07 12:54:47.434840614 -0800
+@@ -8,10 +8,10 @@
+ CFLAGS=-Wall -g -O2 -I.
+
+ default: config.h tnef.h tnef.c
+- $(CC) $(CFLAGS) $(PLATFORM) -c tnef.c
++ $(CC) $(CFLAGS) -fPIC $(PLATFORM) -c tnef.c
+
+ lib: tnef.o
+- ar ruvs tnef.a tnef.o
++ ${AR} ruvs tnef.a tnef.o
+
+ clean:
+ rm -f *.o *.~[ch]
diff --git a/net-mail/ripmime/metadata.xml b/net-mail/ripmime/metadata.xml
new file mode 100644
index 000000000000..51f94e3fbe0e
--- /dev/null
+++ b/net-mail/ripmime/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+</pkgmetadata>
diff --git a/net-mail/ripmime/ripmime-1.4.0.10.ebuild b/net-mail/ripmime/ripmime-1.4.0.10.ebuild
new file mode 100644
index 000000000000..517f67dc46e2
--- /dev/null
+++ b/net-mail/ripmime/ripmime-1.4.0.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="extract attachment files out of a MIME-encoded email pack"
+HOMEPAGE="http://pldaniels.com/ripmime/"
+SRC_URI="http://www.pldaniels.com/ripmime/${P}.tar.gz"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4.0.9-makefile.patch \
+ "${FILESDIR}"/${PN}-1.4.0.9-buffer-overflow.patch
+}
+
+src_compile() {
+ local maketargets="default solib"
+ use static-libs && maketargets="${maketargets} libripmime.a"
+
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" CFLAGS="${CFLAGS}" ${maketargets}
+}
+
+src_install() {
+ dobin ripmime
+ doman ripmime.1
+ dodoc CHANGELOG INSTALL README TODO
+
+ insinto /usr/include/ripmime
+ doins mime.h ripmime-api.h
+
+ dolib.so libripmime.so.1.4.0
+ dosym libripmime.so.1.4.0 /usr/$(get_libdir)/libripmime.so
+ dosym libripmime.so.1.4.0 /usr/$(get_libdir)/libripmime.so.1
+
+ if use static-libs ; then
+ dolib.a libripmime.a
+ fi
+}