summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-06-04 16:42:49 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-06-04 16:44:20 +0200
commit162154b7176361da187986653c605d99904ff78f (patch)
treeee5d2e45fcc4d206e16f121f32f381da7a3a258a /net-mail
parentdev-python/flask-wtf: Enable py3.10 (diff)
downloadgentoo-162154b7176361da187986653c605d99904ff78f.tar.gz
gentoo-162154b7176361da187986653c605d99904ff78f.tar.bz2
gentoo-162154b7176361da187986653c605d99904ff78f.zip
net-mail/fetchmail: add 7.0.0 alpha ebuild (masked)
This adds support for OAUTH2 with helper script, installed with USE=python Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 9a5ec3ab56ae..4554531add33 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,3 +1,4 @@
DIST fetchmail-6.4.16.tar.xz 1316660 BLAKE2B fbe592327c52e9299cb09da9dafbf49e6cbbb2d998929aa30222b879a6c035a653dacda033cf4dec5e31cd90f3ebe4f388b1fd9155e65d29259260f30e658af0 SHA512 5e0d87739d73991c56111222cd84d6e16913b205c4d427feeb9b03d7f330442851f48769e168883ad75afc0a9db9b5267d1ad30e2ca0efe14263befd625dccf0
DIST fetchmail-6.4.19.tar.xz 1316672 BLAKE2B 679d2c49698dd368d32439a8276412e3f32c0a0f6f0e7607bc323c0294c987307469451b4b085fe521f2d5dd4869d59b4841762b6a57b3c654b992e9de8ba87c SHA512 b10f0ac5b3b22f8b1d86367990fc96ea5c49dc21c873890c732c254c34503bd6ab9348c5ef88b99ba0f83f065fa9f9aead55de9721b0f296efa14eac0311daaf
DIST fetchmail-6.4.8.tar.xz 1282300 BLAKE2B 31b7f9fa31edff534210a2a0764cc6dec461968071a8aa29b1d1e9915ff6b8d2949b128f97d72fafe6d431b06d4e5c6b38d4a3cdba06736bdf8ec1879a991798 SHA512 c1052389baafa3a48186733133130bf69b87c8dda8faa00e82f5947037845b95d3271c8183df729728a351888175174ca11eb18f9adb8b3515860cba95ab8987
+DIST fetchmail-7.0.0-alpha8.tar.xz 1212256 BLAKE2B 1b123921a696e60b9c42ea30a379bc6cf46bb66dd630f50e1f10ceac5066932da9538295954be451c4665e1186b7281523bbae83fb4cdb7ad2d1b7b408a3a38f SHA512 fdb20b6a4723f718958e8c800d5a996ff0bb8d9ffe485e8f8429f28953a5a691fd8439c29cb4fbbae338d64c1e9cd1f5f9ed6d89261d0ca582f6345cacb696fe
diff --git a/net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild b/net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild
new file mode 100644
index 000000000000..73e3f2376e41
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-7.0.0_alpha8.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="tk?"
+
+inherit autotools python-single-r1 systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="kerberos nls +python socks +ssl tk"
+REQUIRED_USE="tk? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ >=dev-libs/openssl-1.1.1:=
+ )
+ kerberos? (
+ virtual/krb5
+ >=dev-libs/openssl-1.0.2:=
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use python && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use python || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ use python && python_doscript contrib/fetchmail-oauth2.py
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use python && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}