summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-28 14:32:22 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-28 14:32:40 -0400
commitac1936e82ef20aa73d9ecd7bcb56f7f3ce0cb287 (patch)
tree4884d01d88bb14c4e6135538394d0d34d4bbc423 /net-mail
parentsys-auth/pambase: Version bump (v20201028) (diff)
downloadgentoo-ac1936e82ef20aa73d9ecd7bcb56f7f3ce0cb287.tar.gz
gentoo-ac1936e82ef20aa73d9ecd7bcb56f7f3ce0cb287.tar.bz2
gentoo-ac1936e82ef20aa73d9ecd7bcb56f7f3ce0cb287.zip
net-mail/onionrouter: Add live version
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/onionrouter/onionrouter-9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/onionrouter/onionrouter-9999.ebuild b/net-mail/onionrouter/onionrouter-9999.ebuild
new file mode 100644
index 000000000000..35d74e96b3d0
--- /dev/null
+++ b/net-mail/onionrouter/onionrouter-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+DESCRIPTION=".onion discovery via SRV DNS lookups for use with postfix"
+HOMEPAGE="https://pypi.org/project/onionrouter/ https://github.com/ehloonion/onionrouter/"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ehloonion/onionrouter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://pypi.io/packages/source/${PN::1}/${PN}/${P}.tar.gz"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+')"
+BDEPEND="$(python_gen_cond_dep '
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # https://github.com/ehloonion/onionrouter/pull/15
+ cp "${FILESDIR}/conftest.py" "${S}" || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ insinto /etc/onionrouter
+ doins "${S}/onionrouter/configs/onionrouter.ini"
+}