summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/dropbear/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/dropbear/files')
-rw-r--r--net-misc/dropbear/files/dropbear-0.46-dbscp.patch20
-rw-r--r--net-misc/dropbear/files/dropbear-2013.62-multi-install-man.patch13
-rw-r--r--net-misc/dropbear/files/dropbear-2013.62-multi-no-relink.patch20
-rw-r--r--net-misc/dropbear/files/dropbear.conf.d6
-rw-r--r--net-misc/dropbear/files/dropbear.init.d39
5 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/dropbear/files/dropbear-0.46-dbscp.patch b/net-misc/dropbear/files/dropbear-0.46-dbscp.patch
new file mode 100644
index 000000000000..18873f24c5a6
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear-0.46-dbscp.patch
@@ -0,0 +1,20 @@
+--- dbmulti.c 2005-07-17 07:00:07.000000000 -0400
++++ dbmulti.c 2005-07-17 06:59:35.000000000 -0400
+@@ -60,7 +60,7 @@
+ }
+ #endif
+ #ifdef DBMULTI_scp
+- if (strcmp(progname, "scp") == 0) {
++ if ((strcmp(progname, "scp") == 0) || (strcmp(progname, "dbscp") == 0)) {
+ return scp_main(argc, argv);
+ }
+ #endif
+@@ -81,7 +81,7 @@
+ "'dropbearconvert' - the key converter\n"
+ #endif
+ #ifdef DBMULTI_scp
+- "'scp' - secure copy\n"
++ "'dbscp' - secure copy\n"
+ #endif
+ ,
+ DROPBEAR_VERSION);
diff --git a/net-misc/dropbear/files/dropbear-2013.62-multi-install-man.patch b/net-misc/dropbear/files/dropbear-2013.62-multi-install-man.patch
new file mode 100644
index 000000000000..efaeb8753b00
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear-2013.62-multi-install-man.patch
@@ -0,0 +1,13 @@
+only install man pages that exist as things like scp.1 do not
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -136,7 +136,7 @@ insmulti%: dropbearmulti
+ -rm -f $(DESTDIR)$(bindir)/$*$(EXEEXT)
+ -ln -s $(bindir)/dropbearmulti$(EXEEXT) $(DESTDIR)$(bindir)/$*$(EXEEXT)
+ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
+- $(INSTALL) -m 644 $*.1 $(DESTDIR)$(mandir)/man1/$*.1
++ if test -e $*.1; then $(INSTALL) -m 644 $*.1 $(DESTDIR)$(mandir)/man1/$*.1; fi
+
+ # dropbear should go in sbin, so it needs a seperate rule
+ inst_dropbear: dropbear
diff --git a/net-misc/dropbear/files/dropbear-2013.62-multi-no-relink.patch b/net-misc/dropbear/files/dropbear-2013.62-multi-no-relink.patch
new file mode 100644
index 000000000000..cd12a9634138
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear-2013.62-multi-no-relink.patch
@@ -0,0 +1,20 @@
+turn dropbearmulti into a real target so we don't constantly re-link it
+
+otherwise make has no idea what "multibinary" is and so always re-links it
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -175,10 +175,10 @@ ifeq ($(MULTI),1)
+ CFLAGS+=$(addprefix -DDBMULTI_, $(PROGRAMS)) -DDROPBEAR_MULTI
+ endif
+
+-dropbearmulti: multilink
++dropbearmulti$(EXEEXT): $(HEADERS) $(MULTIOBJS) $(LIBTOM_DEPS) Makefile
++ $(CC) $(LDFLAGS) -o $@ $(MULTIOBJS) $(LIBS)
+
+-multibinary: $(HEADERS) $(MULTIOBJS) $(LIBTOM_DEPS) Makefile
+- $(CC) $(LDFLAGS) -o dropbearmulti$(EXEEXT) $(MULTIOBJS) $(LIBS)
++multibinary: dropbearmulti$(EXEEXT)
+
+ multilink: multibinary $(addprefix link, $(PROGRAMS))
+
diff --git a/net-misc/dropbear/files/dropbear.conf.d b/net-misc/dropbear/files/dropbear.conf.d
new file mode 100644
index 000000000000..555f275d993c
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear.conf.d
@@ -0,0 +1,6 @@
+# /etc/conf.d/dropbear: config file for /etc/init.d/dropbear
+
+# see `dropbear -h` for more information
+# -w disables root logins
+# -p # changes the port number to listen on
+DROPBEAR_OPTS=""
diff --git a/net-misc/dropbear/files/dropbear.init.d b/net-misc/dropbear/files/dropbear.init.d
new file mode 100644
index 000000000000..bbc314852bc3
--- /dev/null
+++ b/net-misc/dropbear/files/dropbear.init.d
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use logger dns
+ need net
+}
+
+check_config() {
+ mkdir -p /etc/dropbear
+
+ local t k
+ for t in dss rsa ecdsa; do
+ k="/etc/dropbear/dropbear_${t}_host_key"
+ if [ ! -e ${k} ] ; then
+ # See if support is enabled for this key type.
+ if dropbearkey -h 2>&1 | grep -q " ${t}$" ; then
+ einfo "Generating ${k} ..."
+ dropbearkey -t ${t} -f ${k} >/dev/null
+ fi
+ fi &
+ done
+ wait
+}
+
+start() {
+ check_config || return 1
+ ebegin "Starting dropbear"
+ dropbear ${DROPBEAR_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping dropbear"
+ start-stop-daemon --stop --pidfile /var/run/dropbear.pid
+ eend $?
+}