summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-06 15:52:48 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-06 16:44:44 -0400
commitc09e4b7cfb3c84a29dd2c66beb30fb5128078088 (patch)
treea6036761bbe0bfd1876cf454308c117485014f89 /net-misc/ices/ices-2.0.2-r2.ebuild
parentnet-misc/ices: EAPI7->8, tidy, fix prefix, more pedantic deps (diff)
downloadgentoo-c09e4b7cfb3c84a29dd2c66beb30fb5128078088.tar.gz
gentoo-c09e4b7cfb3c84a29dd2c66beb30fb5128078088.tar.bz2
gentoo-c09e4b7cfb3c84a29dd2c66beb30fb5128078088.zip
net-misc/ices: fix build with clang/lld and upcoming clang-16
One configure test was broken with (any) clang/lld on multilib profiles due to passing -L/usr/lib which led to underlinking wrt #740794. For 16 it's the usual missing header, handled by adjusting the autoconf test (revbumped in previous commit at same time for other compilers). Closes: https://bugs.gentoo.org/740794 Closes: https://bugs.gentoo.org/870973 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ices/ices-2.0.2-r2.ebuild')
-rw-r--r--net-misc/ices/ices-2.0.2-r2.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/net-misc/ices/ices-2.0.2-r2.ebuild b/net-misc/ices/ices-2.0.2-r2.ebuild
index 5e79e9e7469a..4f8c7a6de887 100644
--- a/net-misc/ices/ices-2.0.2-r2.ebuild
+++ b/net-misc/ices/ices-2.0.2-r2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
HOMEPAGE="https://icecast.org/ices/"
SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
@@ -22,6 +24,17 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-libogg-test.patch
+ "${FILESDIR}"/${P}-gettimeofday.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf #740794,870973
+}
+
src_configure() {
econf --sysconfdir="${EPREFIX}"/etc/ices2
}