summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-06-24 10:46:41 +0200
committerJeroen Roovers <jer@gentoo.org>2019-06-24 11:08:05 +0200
commit91d82c596a20d53dc4f119117b771dd945d07d11 (patch)
tree27847a58657ff377c030d59fb24f2e5164a10727 /net-misc/iperf
parentdev-python/ruamel-std-pathlib: put myself first in maintainers list (diff)
downloadgentoo-91d82c596a20d53dc4f119117b771dd945d07d11.tar.gz
gentoo-91d82c596a20d53dc4f119117b771dd945d07d11.tar.bz2
gentoo-91d82c596a20d53dc4f119117b771dd945d07d11.zip
net-misc/iperf: Version 3.7
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-misc/iperf')
-rw-r--r--net-misc/iperf/Manifest1
-rw-r--r--net-misc/iperf/iperf-3.7.ebuild36
-rw-r--r--net-misc/iperf/iperf-3.99999.99999.ebuild13
-rw-r--r--net-misc/iperf/metadata.xml2
4 files changed, 45 insertions, 7 deletions
diff --git a/net-misc/iperf/Manifest b/net-misc/iperf/Manifest
index b6e6ccb1364a..46828cba4c72 100644
--- a/net-misc/iperf/Manifest
+++ b/net-misc/iperf/Manifest
@@ -1,2 +1,3 @@
DIST iperf-2.0.13.tar.gz 326148 BLAKE2B 2a40aea9e2d7fdc935b91be5e4e586bf68dd27604375d2570570145e5db1ea5837469a4989f47586986932bef33cba05ed19ed3a9ce40c0a5531581c6d3ba982 SHA512 40fcfb8f4d27887f53a743ac07396511fb2a7ac59f4b300fe36896bd0241e191945fa253705990711772ee776d5e4227ed62760fc92abebdfebcedd11c27c0ea
DIST iperf-3.6.tar.gz 602406 BLAKE2B 791355c52e587bae01560e14448b92c3e4e070afc4f311964d2577ea790886777ca1512ea349d105a83f312f795800c01e13c53b700511df14bcf2a7c28f5dda SHA512 0a1c8fd9b33369a2a018423cf33e63cfe7202ae411996f467199ae5b834ff7977d0e5c7e342f4f1b7d90c1c156453daa4dac9f94d11bb581d6d43c807538206d
+DIST iperf-3.7.tar.gz 609874 BLAKE2B a2abd640004713a0d805be4779e5fd17a7a5ce58ef67cbb0ce8050e30000465686466b30b699b2d8cb374be6b5a063ce220cb79e48fa8fd2257cce69cd8a90e8 SHA512 4a861a506d7e37958e1af62d1634d11c4937d5974bfce636d421aa80c88f038c96738d9e196a7667e38ef515f998b467d4ff3db30af7e3efea8d9ac8a63a61e7
diff --git a/net-misc/iperf/iperf-3.7.ebuild b/net-misc/iperf/iperf-3.7.ebuild
new file mode 100644
index 000000000000..9b5ce32eaae2
--- /dev/null
+++ b/net-misc/iperf/iperf-3.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="${HOMEPAGE}archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint"
+IUSE="libressl profiling sctp static-libs"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sctp? ( net-misc/lksctp-tools )
+"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${P/_/}
+
+src_configure() {
+ use sctp || export ac_cv_header_netinet_sctp_h=no
+ econf \
+ $(use_enable profiling) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/iperf.confd iperf3
+ newinitd "${FILESDIR}"/iperf3.initd iperf3
+ prune_libtool_files
+}
diff --git a/net-misc/iperf/iperf-3.99999.99999.ebuild b/net-misc/iperf/iperf-3.99999.99999.ebuild
index 27de50197b1e..5dc516b75b6c 100644
--- a/net-misc/iperf/iperf-3.99999.99999.ebuild
+++ b/net-misc/iperf/iperf-3.99999.99999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,18 +13,19 @@ SLOT="3"
KEYWORDS=""
IUSE="libressl profiling sctp static-libs"
-DEPEND="!libressl? ( dev-libs/openssl:0= )
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
- sctp? ( net-misc/lksctp-tools )"
+ sctp? ( net-misc/lksctp-tools )
+"
RDEPEND="${DEPEND}"
-
S=${WORKDIR}/${P/_/}
src_configure() {
use sctp || export ac_cv_header_netinet_sctp_h=no
econf \
- $(use_enable static-libs static) \
- $(use_enable profiling)
+ $(use_enable profiling) \
+ $(use_enable static-libs static)
}
src_install() {
diff --git a/net-misc/iperf/metadata.xml b/net-misc/iperf/metadata.xml
index f3c92356707b..344d7ddf0bf3 100644
--- a/net-misc/iperf/metadata.xml
+++ b/net-misc/iperf/metadata.xml
@@ -10,6 +10,6 @@
<remote-id type="sourceforge">iperf</remote-id>
</upstream>
<use>
-<flag name='profiling'>Create a profiled iperf3 binary</flag>
+<flag name='profiling'>Install profiled iperf3 binary iperf3_profile</flag>
</use>
</pkgmetadata>