summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-11-29 10:54:05 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-11-29 10:57:18 +0100
commitb4969d13c56e7d24d75cad721c302b371160fc00 (patch)
tree0680615941340461460a26c974540e66ebf0da69 /net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild
parentnet-misc/pyhoca-cli: drop old (diff)
downloadgentoo-b4969d13c56e7d24d75cad721c302b371160fc00.tar.gz
gentoo-b4969d13c56e7d24d75cad721c302b371160fc00.tar.bz2
gentoo-b4969d13c56e7d24d75cad721c302b371160fc00.zip
net-misc/pyhoca-cli: 0.6.1.1 bump
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild')
-rw-r--r--net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild
new file mode 100644
index 000000000000..30c368003023
--- /dev/null
+++ b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="X2Go command line client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
+ >=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install() {
+ distutils-r1_python_install
+ python_doscript ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/man1/*
+ find "${ED}" -name '*.pth' -delete || die
+}