summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2023-05-10 19:41:22 +0300
committerSam James <sam@gentoo.org>2023-05-13 04:30:59 +0100
commit222b2e3d77ba28bc281f964239c7d56e3c6630bb (patch)
treec8877e9b44f7df8902e074227268127aa3a60dfc /net-misc/r8125
parentnet-libs/libmicrohttpd: fixed license (diff)
downloadgentoo-222b2e3d77ba28bc281f964239c7d56e3c6630bb.tar.gz
gentoo-222b2e3d77ba28bc281f964239c7d56e3c6630bb.tar.bz2
gentoo-222b2e3d77ba28bc281f964239c7d56e3c6630bb.zip
net-misc/r8125: added new version 9.011.01
Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/r8125')
-rw-r--r--net-misc/r8125/Manifest1
-rw-r--r--net-misc/r8125/r8125-9.011.01.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/r8125/Manifest b/net-misc/r8125/Manifest
index 56ef9e521565..e514276a4494 100644
--- a/net-misc/r8125/Manifest
+++ b/net-misc/r8125/Manifest
@@ -2,3 +2,4 @@ DIST r8125-9.008.00.tar.bz2 89622 BLAKE2B d1106086d1bca53484f8536072cddd506087b5
DIST r8125-9.009.01.tar.bz2 89897 BLAKE2B 65f64f504cedc7244bdae10fd1638e031eb103f562cd71d32b5f36b15541704086df8cea16829b289e8be61bacf3de559616884d1672a4d6b8e47211816de8d3 SHA512 8b717447e2048df0d88d8350da2edb58f704e893498fbebea4aa2a3ac45ea050d70e73e78d41ab94562228b9c01e6fe59810c501c5bb880db446c05b9b6aee0d
DIST r8125-9.009.02.tar.bz2 89916 BLAKE2B 2dd8ad226f8ad9dd4e6646cdce66f0c12a6a657aa39c6e91892f410780ed245046fc94f247939958db7b950aa045e011716ecd7f6ebb6099ca3d9ffc54cfd0de SHA512 29bfe60410727f09b004f172e5046292eff511dfca5af8a21c24719e4068925103ba12af0ce808316ef206b329ce886693e7330c1c68d8e77fc50ab40bd7dcfe
DIST r8125-9.011.00.tar.bz2 98082 BLAKE2B 306a4fc36149986a24d73cfc3f78e2494a71977640cf7676ae17c2d4f5cff1bf3f5a7ca209fa83bb43a8770acbdc45290b29bbbacc418518271ac316bef9cdd1 SHA512 c2efce2d01025d5dbbd3552390e157b0859ee7ea4e9200d44af61efd7531362bd9f754b5728c89aa2c287915f99492c84c52ee11eec1a4d759bf4228ca75a6c4
+DIST r8125-9.011.01.tar.bz2 97867 BLAKE2B 0981c71795d3e839b97f7b41dbaddcc0743676c6bd0b656258e6e9b2e0879128ae4869e9ab3ab837d0ae10eb8c963177c3779b4e4a69d8a5c3d95b7b8d54f9c5 SHA512 833199cc0ce8179ef93c202fc89d4c4368b73e9515d1ef2550ebb209243dd2c8943aa9f267903d8fa21c46304b7703410f1c354d4ce1b6f6aee7ece97017dba2
diff --git a/net-misc/r8125/r8125-9.011.01.ebuild b/net-misc/r8125/r8125-9.011.01.ebuild
new file mode 100644
index 000000000000..d09aaaa2e674
--- /dev/null
+++ b/net-misc/r8125/r8125-9.011.01.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info linux-mod
+
+DESCRIPTION="r8125 vendor driver for Realtek RTL8125 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+SRC_URI="http://rtitwww.realtek.com/rtdrivers/cn/nic1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8125(net:${S}/src)"
+BUILD_TARGETS="modules"
+IUSE="+multi-tx-q ptp +rss use-firmware"
+
+CONFIG_CHECK="~!R8169"
+WARNING_R8169="CONFIG_R8169 is enabled. ${PN} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+ BUILD_PARAMS+=" ENABLE_PTP_SUPPORT=$(usex ptp y n)"
+ BUILD_PARAMS+=" ENABLE_RSS_SUPPORT=$(usex rss y n)"
+ BUILD_PARAMS+=" ENABLE_MULTIPLE_TX_QUEUE=$(usex multi-tx-q y n)"
+ BUILD_PARAMS+=" ENABLE_USE_FIRMWARE_FILE=$(usex use-firmware y n)"
+ BUILD_PARAMS+=" ENABLE_PAGE_REUSE=y ENABLE_RX_PACKET_FRAGMENT=y"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+}