summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 05:05:49 +0000
committerSam James <sam@gentoo.org>2021-10-31 05:05:49 +0000
commit58996c17fc14caab6f1a678b5d326be0e76b94a4 (patch)
tree314552d2040cbc219154b5ac79eab7183cd0ba57 /net-misc/spice-gtk
parentprofiles/default/linux/uclibc: mark deprecated (diff)
downloadgentoo-58996c17fc14caab6f1a678b5d326be0e76b94a4.tar.gz
gentoo-58996c17fc14caab6f1a678b5d326be0e76b94a4.tar.bz2
gentoo-58996c17fc14caab6f1a678b5d326be0e76b94a4.zip
net-misc/spice-gtk: fix finding newer pyparsing
Closes: https://bugs.gentoo.org/820074 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch13
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.39-r1.ebuild8
2 files changed, 19 insertions, 2 deletions
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch b/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch
new file mode 100644
index 000000000000..9a3cdd090063
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch
@@ -0,0 +1,13 @@
+https://gitlab.freedesktop.org/spice/spice-common/-/issues/5
+https://bugs.gentoo.org/820074
+--- a/subprojects/spice-common/meson.build
++++ b/subprojects/spice-common/meson.build
+@@ -132,7 +132,7 @@ if spice_common_generate_client_code or spice_common_generate_server_code
+ if get_option('python-checks')
+ foreach module : ['six', 'pyparsing']
+ message('Checking for python module @0@'.format(module))
+- cmd = run_command(python, '-m', module)
++ cmd = run_command(python, '-c', 'import @0@'.format(module))
+ if cmd.returncode() != 0
+ error('Python module @0@ not found'.format(module))
+ endif
diff --git a/net-misc/spice-gtk/spice-gtk-0.39-r1.ebuild b/net-misc/spice-gtk/spice-gtk-0.39-r1.ebuild
index 7005e220e2e1..08fdbf6d9fa4 100644
--- a/net-misc/spice-gtk/spice-gtk-0.39-r1.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.39-r1.ebuild
@@ -79,9 +79,13 @@ BDEPEND="
')
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.39-fix-finding-pyparsing.patch
+)
+
python_check_deps() {
- has_version "dev-python/six[${PYTHON_USEDEP}]" &&
- has_version "dev-python/pyparsing[${PYTHON_USEDEP}]"
+ has_version -b "dev-python/six[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pyparsing[${PYTHON_USEDEP}]"
}
src_prepare() {