summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-17 05:29:58 +0000
committerSam James <sam@gentoo.org>2024-02-17 05:29:58 +0000
commit0148240ff8873b86bcb50a1069e8284e67b427e0 (patch)
tree801d793b35d5a969f0de848adc4fb323958fd445 /net-misc/streamlink
parentnet-misc/dhcpcd: backport crash fix ("every 5 days") (diff)
downloadgentoo-0148240ff8873b86bcb50a1069e8284e67b427e0.tar.gz
gentoo-0148240ff8873b86bcb50a1069e8284e67b427e0.tar.bz2
gentoo-0148240ff8873b86bcb50a1069e8284e67b427e0.zip
net-misc/streamlink: add 6.6.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-6.6.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 624a699b2717..7de83672e6fa 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,2 +1,3 @@
DIST streamlink-6.5.0.tar.gz 715983 BLAKE2B f680d034f3f5c66609c1e26f2061f34d6aa8f233d9bb8ac238b675bf12bc69751e48df4f222b7d6f6e25697664afccc01b1fedc14410d5e3a47eaed0ad591af6 SHA512 affd45d1b17704768a405b389f9696090917e5cc73b0e22455e7f944eb0798dae7b23f73a728d3641fb43a5104e731816442be0e6f05a04a5bfe132c28d5491c
DIST streamlink-6.5.1.tar.gz 717297 BLAKE2B 7f24a9ac2e62ff08d2126e4aceda75cbd46d78de08784336dd3b4d7608cd7885a5dca28bd9dda9f8c217b9cc428f8f50f09d0c45e470e0d3534ecd3effb2a95f SHA512 b31b34a2ef510d47d396b12b770c042bed24ff61835db6a654722803ae94e8371aa547f30bf20d7cf34d737ed9bd59bcea1bb1810e926cfc7ae3fa72f38881d8
+DIST streamlink-6.6.0.tar.gz 736387 BLAKE2B ede3f9d31d3676f3909a37bb6a6f172ed5ac7bac8eaff65315bfeb69db2869004c2a4a96c425202522b1deb43df7e300db3bdd425b9799c109c3b27b65386966 SHA512 db67b79ee5d6c26b8d6ec6ade28a126d25b96981b606a26f6fa54c2d8c8c49744674c1ac7c198a988dd44f82f8c2b159f76300321de8c06f1bd633ac6ba4a301
diff --git a/net-misc/streamlink/streamlink-6.6.0.ebuild b/net-misc/streamlink/streamlink-6.6.0.ebuild
new file mode 100644
index 000000000000..da450aa9f963
--- /dev/null
+++ b/net-misc/streamlink/streamlink-6.6.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+# >= 6.2.1 uses a bunch of setuptools hooks instead of vanilla setuptools
+# https://github.com/streamlink/streamlink/commit/194d9bc193f5285bc1ba33af5fd89209a96ad3a7
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+# See https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358 for chardet/charset-normalizer dep
+RDEPEND="
+ media-video/ffmpeg
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ || (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ )
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/setuptools-64[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+if [[ ${PV} == 9999* ]]; then
+ RDEPEND+="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+ "
+fi
+
+distutils_enable_tests pytest