summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-20 17:32:00 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-20 17:32:11 +0300
commit45f0c1559c2559bc200ec7e9ef19f3c3e2e3a626 (patch)
treeb6d02b05c2938685dd6567d260feac25dcd317cf /net-misc/teamviewer
parentapp-emacs/emacs-daemon: Drop dependency on virtual/emacs. (diff)
downloadgentoo-45f0c1559c2559bc200ec7e9ef19f3c3e2e3a626.tar.gz
gentoo-45f0c1559c2559bc200ec7e9ef19f3c3e2e3a626.tar.bz2
gentoo-45f0c1559c2559bc200ec7e9ef19f3c3e2e3a626.zip
net-misc/teamviewer: Version bump (v15.1.3937)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'net-misc/teamviewer')
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/teamviewer-15.1.3937.ebuild136
2 files changed, 138 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index 8dfd6d296435..06984b6c963e 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -1,2 +1,4 @@
DIST teamviewer_15.0.8397_amd64.tar.xz 12532076 BLAKE2B a66cc74961edb1eb28b38a77aa29a18c91c86703334903f33e6a7d9cd4dcedcfd92d51636c2908eaa38ff0f024eca97f8b1ad63c396f033efa5039b9fccff5a9 SHA512 f4c9fb9da1b7af9fa1d798c67eb014e906684dab05b41d5618ec21732a4b9b917e7d51e185ca58bc811c8e869f7171136e5a405f9ffd7e8fa5d0b2c7952ed68a
DIST teamviewer_15.0.8397_i386.tar.xz 13019240 BLAKE2B b14dc20b31d888297602baae65c9ec802e5104f8169090ca3f88b87814f58b81585b9d5b89bfe8478d767b30612ad05ccf2d6a659046c0c5e75bfa287436e06c SHA512 4e1d6101ae8a91e03c6580407857df76505dd216baf172de6a7d00ea308318b8b326f0d15e1d8819ede4d7d758c65608c4446abcfc52ba224e56ab11a623aa65
+DIST teamviewer_15.1.3937_amd64.tar.xz 12898448 BLAKE2B fea1d64c04c5c4f04237ab639b1faf1c6fb027fa5f4824f8a9c0ed31b52894c7a22130d0871dba98388ccf073a5393973350a3e3ea88f94bc5958196a6bb8934 SHA512 23fc65a676570c291184a5c89ce05998cb70ec822d764264de7afaffa47a862e3eb0a4ae9364064fa831165be901dc0b85cb5b79181b8b833638d720504dee5c
+DIST teamviewer_15.1.3937_i386.tar.xz 13443796 BLAKE2B aa9c5f3cd42a123c38a567a117c919c829e089e4c81cf4b6fca0559351895c3824b7a117ac7dc64c9f1129e0cd44dd2347e57644080559a86640a9d8bffbe62a SHA512 8054e5e3901d60bbf210b03209da8afaab03ba95529d1a107a23401a7561c5ee0c33a43837f84490667f0fa282fe8a74087473b7f51f604b675e87d87522302d
diff --git a/net-misc/teamviewer/teamviewer-15.1.3937.ebuild b/net-misc/teamviewer/teamviewer-15.1.3937.ebuild
new file mode 100644
index 000000000000..7c717766d4a1
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-15.1.3937.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN}${PV/\.*}
+inherit desktop gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+ !sys-auth/consolekit
+"
+
+# For consolekit incompatibility see https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+ sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+ -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+ local dst="/opt/${MY_PN}" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ # No slotting here, binary expects this service path
+ newinitd "${FILESDIR}"/teamviewerd15.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+ done
+
+ # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+ # have the undesired result of installing subdirectory 'doc' in /usr/
+ # share/doc/teamviewer-<version>)
+ for doc in $(find doc -type f); do
+ dodoc ${doc}
+ done
+
+ keepdir /etc/${MY_PN}
+ dosym ../../etc/${MY_PN} ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/${MY_PN}
+ dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "Please note that parallel installation of multiple versions of"
+ elog "TeamViewer is currently not supported at runtime. Bug #621818"
+ elog ""
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ teamviewer help"
+ elog
+ elog "Most likely TeamViewer will work normally only on systems with systemd"
+ elog "or elogind. See this thread for additional info:"
+ elog "https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}