summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-25 23:44:36 +0000
committerSam James <sam@gentoo.org>2022-03-26 00:00:34 +0000
commitb8945ea9d88b392111975fa2e8299e3a92b14bae (patch)
tree0786a64b40941f34d7565b4e8131dd57dceb5349 /net-misc/uftp
parentnet-misc/efax: [QA] fix tc-get* quoting (diff)
downloadgentoo-b8945ea9d88b392111975fa2e8299e3a92b14bae.tar.gz
gentoo-b8945ea9d88b392111975fa2e8299e3a92b14bae.tar.bz2
gentoo-b8945ea9d88b392111975fa2e8299e3a92b14bae.zip
net-misc/uftp: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/uftp')
-rw-r--r--net-misc/uftp/uftp-4.10.1-r1.ebuild7
-rw-r--r--net-misc/uftp/uftp-5.0-r1.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/net-misc/uftp/uftp-4.10.1-r1.ebuild b/net-misc/uftp/uftp-4.10.1-r1.ebuild
index b85e46fc8aa2..cd876c63f416 100644
--- a/net-misc/uftp/uftp-4.10.1-r1.ebuild
+++ b/net-misc/uftp/uftp-4.10.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,8 +28,9 @@ PATCHES=(
src_compile() {
use ssl || local opt="NO_ENCRYPTION=1"
- emake CC=$(tc-getCC) $opt uftp uftp_keymgt
- use server && emake CC=$(tc-getCC) $opt uftpd uftpproxyd
+
+ emake CC="$(tc-getCC)" ${opt} uftp uftp_keymgt
+ use server && emake CC="$(tc-getCC)" ${opt} uftpd uftpproxyd
}
src_install() {
diff --git a/net-misc/uftp/uftp-5.0-r1.ebuild b/net-misc/uftp/uftp-5.0-r1.ebuild
index 4df140fe4cbc..2720099e81a7 100644
--- a/net-misc/uftp/uftp-5.0-r1.ebuild
+++ b/net-misc/uftp/uftp-5.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,8 +24,9 @@ PATCHES=(
src_compile() {
use ssl || local opt="NO_ENCRYPTION=1"
- emake CC=$(tc-getCC) $opt uftp uftp_keymgt
- use server && emake CC=$(tc-getCC) $opt uftpd uftpproxyd
+
+ emake CC="$(tc-getCC)" ${opt} uftp uftp_keymgt
+ use server && emake CC="$(tc-getCC)" ${opt} uftpd uftpproxyd
}
src_install() {