summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-01-27 12:57:45 +0100
committerSam James <sam@gentoo.org>2021-03-05 19:56:46 +0000
commit193dfb05dd5d2b884574f78a6f5972bf2781d6f6 (patch)
treeb7f7234b1a744df08c7ec81e031756f3f194a254 /net-misc/unison/unison-2.51.3_p20201127.ebuild
parentnet-misc/unison: bump to 2.51.4_rc1 (diff)
downloadgentoo-193dfb05dd5d2b884574f78a6f5972bf2781d6f6.tar.gz
gentoo-193dfb05dd5d2b884574f78a6f5972bf2781d6f6.tar.bz2
gentoo-193dfb05dd5d2b884574f78a6f5972bf2781d6f6.zip
net-misc/unison: fix graphical UI logic in 2.51.3_p20201127
Use same logic as 2.51.4_rc1. Bug: https://bugs.gentoo.org/758386 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/19043 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/unison/unison-2.51.3_p20201127.ebuild')
-rw-r--r--net-misc/unison/unison-2.51.3_p20201127.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-misc/unison/unison-2.51.3_p20201127.ebuild b/net-misc/unison/unison-2.51.3_p20201127.ebuild
index a035fe9b7214..a0420d55da8e 100644
--- a/net-misc/unison/unison-2.51.3_p20201127.ebuild
+++ b/net-misc/unison/unison-2.51.3_p20201127.ebuild
@@ -39,7 +39,7 @@ src_prepare() {
}
src_compile() {
- local myconf="all"
+ local myconf
if use threads; then
myconf="$myconf THREADS=true"
@@ -57,13 +57,12 @@ src_compile() {
use ocamlopt || myconf="$myconf NATIVE=false"
- # Discard cflags as it will try to pass them to ocamlc...
- emake $myconf CFLAGS=""
-
if use doc; then
- myconf="$myconf docs HEVEA=false"
- emake $myconf CFLAGS=""
+ emake $myconf CFLAGS="" HEVEA=false docs
fi
+
+ # Discard cflags as it will try to pass them to ocamlc...
+ emake $myconf CFLAGS="" src
}
src_test() {