summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-01 18:22:32 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-01 18:56:57 -0400
commit2b6aa605cc3d91fdc868e3a06167f4aaf4a90944 (patch)
treef57de82e89c9cddf2b5facdd091de23ccff9d906 /net-misc/yt-dlp
parentdev-vcs/pre-commit: Stabilize 3.7.1 x86, #937063 (diff)
downloadgentoo-2b6aa605cc3d91fdc868e3a06167f4aaf4a90944.tar.gz
gentoo-2b6aa605cc3d91fdc868e3a06167f4aaf4a90944.tar.bz2
gentoo-2b6aa605cc3d91fdc868e3a06167f4aaf4a90944.zip
net-misc/yt-dlp: add 2024.08.01
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.08.01.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 5f159bef3b2d..4681b72ada35 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,2 +1,3 @@
DIST yt-dlp-2024.07.16.tar.gz 5688157 BLAKE2B a1e4cd8ff7b73246aed2239298d548945c99fe8d76d41b9e3293767b7b680028f4d23f2fc116516e853be163b267a600f99525784d9b3cc16280f1b8b2d5a90a SHA512 17f5aa71ae01b6a009e5b0a4380d9329530563ee01ac268a2a6acff01732ce0c9d14181790a15b182b0de09a35b6db2f3e814acc50934d5f3e361245027926e9
DIST yt-dlp-2024.07.25.tar.gz 5695273 BLAKE2B 95cad2c1e1c51bf67d983cca38479426e9e526e1113bcab9522c10e9b2b5421fb5931e51b2f2d59057c9ba5646864bd62d801b0f0fed31fb0d240c29176a3963 SHA512 96483979cd6c7000d6bb9a687835331ce9c894c533e5d498dc54e5b85d31d53f1c053779499e4087dc7542d89668a2b8dc977242c770422a076527da24567c77
+DIST yt-dlp-2024.08.01.tar.gz 5708569 BLAKE2B 83659efb7de95792e28edd8f43103c73141ffb9e3492baaf3533759329e36f8fc84da5a45a281ca394664a67c0723019de89f43362c24ff026c4cdd6158f04b5 SHA512 e454969e641f2e36cf1deae142a0eddfb54eb9dc19601066e129d597304cb28550b08b2a5923e7ebf7133e7793fcd6b3006d7b19040f37d40450854f4fe06247
diff --git a/net-misc/yt-dlp/yt-dlp-2024.08.01.ebuild b/net-misc/yt-dlp/yt-dlp-2024.08.01.ebuild
new file mode 100644
index 000000000000..a4bd878780a8
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.08.01.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}