summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-13 22:01:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-14 00:02:49 -0400
commitf7d92d2c8e00f41bfcb6aedd8bff71b7f0fdb2c1 (patch)
tree0e0a9145453bf5d01c0cbad091d61bcd14fa6afa /net-misc/ytfzf
parentapp-emulation/ruffle: sync live (diff)
downloadgentoo-f7d92d2c8e00f41bfcb6aedd8bff71b7f0fdb2c1.tar.gz
gentoo-f7d92d2c8e00f41bfcb6aedd8bff71b7f0fdb2c1.tar.bz2
gentoo-f7d92d2c8e00f41bfcb6aedd8bff71b7f0fdb2c1.zip
net-misc/ytfzf: add 2.5.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/files/ytfzf-2.5.0-cachedir.patch16
-rw-r--r--net-misc/ytfzf/ytfzf-2.5.0.ebuild63
3 files changed, 80 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 77eab4c37ce4..4a94a807b041 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.4.1.tar.gz 3256903 BLAKE2B e95fc86d1ed2099aeb96d8daf808861e279865e17758dc8b0b5fa4c349dd819371012d13073f89b94469f1d69f00b66bb01860e3190e324baadc30e2cbae8074 SHA512 f0be168d5fd32cc75f95d0533a093cb9e3aa238d39e024271d69f078b974da51504bd1fd65a34378085a148f1ddae68f6c2fdc15c7a56c2353ec3d6695451771
+DIST ytfzf-2.5.0.tar.gz 3260280 BLAKE2B 33535afc6be18fe9efeddf666ccdc646db227fcb601a52baeaca91b9316b87b1300fdab50ceca5eb9e21fef5571a87e917f78f71b97e7ec2abbebf5158b4487d SHA512 43e366694687be517a0b3da0d16e423f32046ab5de92368748e87c622f43e34bd1037f01b37fcb05ae8ce87ca536672cf3f5ca2b2608bab07ec9f4abeabb61ec
diff --git a/net-misc/ytfzf/files/ytfzf-2.5.0-cachedir.patch b/net-misc/ytfzf/files/ytfzf-2.5.0-cachedir.patch
new file mode 100644
index 000000000000..11023779e690
--- /dev/null
+++ b/net-misc/ytfzf/files/ytfzf-2.5.0-cachedir.patch
@@ -0,0 +1,16 @@
+https://github.com/pystardust/ytfzf/commit/cfc739211352b0d5249e48419a34ee6e1913aadd
+From: Euro20179 <sandollar2020@gmail.com>
+Date: Tue, 13 Sep 2022 18:50:36 -0700
+Subject: [PATCH] fix: if cache dir is missing, ytfzf complains when trying to
+ create instances.json
+--- a/ytfzf
++++ b/ytfzf
+@@ -2278,6 +2278,8 @@ do_an_event_function "on_post_set_vars"
+ # files
+ : "${hist_file:="$cache_dir/watch_hist"}" "${search_hist_file:="$cache_dir/search_hist"}"
+
++[ ! -d "$cache_dir" ] && mkdir -p "$cache_dir"
++
+ # Where do we put the list of healthy instances?
+ : "${instances_file:="$cache_dir/instances.json"}"
+
diff --git a/net-misc/ytfzf/ytfzf-2.5.0.ebuild b/net-misc/ytfzf/ytfzf-2.5.0.ebuild
new file mode 100644
index 000000000000..743a99d9afe1
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.5.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X minimal"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ virtual/awk
+ !minimal? (
+ X? ( media-gfx/ueberzug )
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cachedir.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "/^: ...YTFZF_SYSTEM_ADDON_DIR/s|/usr/local|${EPREFIX}/usr|" ytfzf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}