summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-05-27 16:11:27 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-05-27 16:11:51 +0200
commit04a1aade2834f9e3ccc9e1e94cb10072eeb11743 (patch)
tree59263adf32de822a9b6d1ca2e1b3c46c2db9d09e /net-misc
parentapp-text/discount: drop 2.2.7-r2 this time (diff)
downloadgentoo-04a1aade2834f9e3ccc9e1e94cb10072eeb11743.tar.gz
gentoo-04a1aade2834f9e3ccc9e1e94cb10072eeb11743.tar.bz2
gentoo-04a1aade2834f9e3ccc9e1e94cb10072eeb11743.zip
net-misc/wget2: Bump to version 2.0.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget2/Manifest1
-rw-r--r--net-misc/wget2/wget2-2.0.1.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/net-misc/wget2/Manifest b/net-misc/wget2/Manifest
index 6ea85dbe2ae0..69b5cbd09779 100644
--- a/net-misc/wget2/Manifest
+++ b/net-misc/wget2/Manifest
@@ -1 +1,2 @@
DIST wget2-2.0.0.tar.gz 3565643 BLAKE2B 8792950942c88aceed41aa1d00b2c39d55e057795d0f68e8bfe9a1da548161aa49eaa82d13e8ea3e14cccee4423d41f9643baff1007361c26464b10683a8ef88 SHA512 59be98a43057220f4eb4314d0876990c21bbc2606a82444e03282ca55d6de18a382fb75b3fcbb1e7f5a5930cd9a81c6c73cdac2ffba3932b55816fb8140c00eb
+DIST wget2-2.0.1.tar.gz 3780748 BLAKE2B cc28c58ab59c28540259545d60b19d6c513725e856fce02690e40ab0818d213bd656de704bd6310650af7190d7d3265fee859eebab326ad441f7351213fce6d3 SHA512 7a4afebf87ecda9e7e2d1fb2861c220875a96bab7c7ead6397c7ac11b6effae80d80f71b57a58d6b91a6c849b9a9fd974ce620d3050f677dd0fc4bc05358b27e
diff --git a/net-misc/wget2/wget2-2.0.1.ebuild b/net-misc/wget2/wget2-2.0.1.ebuild
new file mode 100644
index 000000000000..57cdc0a2f977
--- /dev/null
+++ b/net-misc/wget2/wget2-2.0.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
+HOMEPAGE="https://gitlab.com/gnuwget/wget2"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://gitlab.com/gnuwget/wget2.git"
+else
+ SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-3"
+SLOT="0/0" # subslot = libwget.so version
+IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzma openssl pcre psl +ssl test valgrind xattr zlib"
+REQUIRED_USE="valgrind? ( test )"
+
+RDEPEND="
+ brotli? ( app-arch/brotli )
+ bzip2? ( app-arch/bzip2 )
+ !gnutls? ( dev-libs/libgcrypt:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ )
+ gpgme? (
+ app-crypt/gpgme:=
+ dev-libs/libassuan
+ dev-libs/libgpg-error
+ )
+ http2? ( net-libs/nghttp2 )
+ idn? ( net-dns/libidn2:= )
+ lzma? ( app-arch/xz-utils )
+ pcre? ( dev-libs/libpcre2 )
+ psl? ( net-libs/libpsl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ valgrind? ( dev-util/valgrind )
+"
+
+RESTRICT="!test? ( test )"
+
+src_unpack() {
+ if [[ "${PV}" == *9999 ]] ; then
+ git-r3_src_unpack
+
+ # We need to mess with gnulib :-/
+ EGIT_REPO_URI="https://git.savannah.gnu.org/r/gnulib.git" \
+ EGIT_CHECKOUT_DIR="${WORKDIR}/gnulib" \
+ git-r3_src_unpack
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+ if [[ "${PV}" == *9999 ]] ; then
+ local bootstrap_opts=(
+ --gnulib-srcdir=../gnulib
+ --no-bootstrap-sync
+ --copy
+ --no-git
+ --skip-po
+ )
+ AUTORECONF="/bin/true" \
+ LIBTOOLIZE="/bin/true" \
+ sh ./bootstrap "${bootstrap_opts[@]}" || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --with-plugin-support
+ --with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
+ --without-libidn
+ --without-libmicrohttpd
+ $(use_enable doc)
+ $(use_enable valgrind valgrind-tests)
+ $(use_enable xattr)
+ $(use_with brotli brotlidec)
+ $(use_with bzip2)
+ $(use_with gpgme)
+ $(use_with http2 libnghttp2)
+ $(use_with idn libidn2)
+ $(use_with lzma)
+ $(use_with pcre libpcre2)
+ $(use_with psl libpsl)
+ $(use_with zlib)
+
+ # Avoid calling ldconfig
+ LDCONFIG=:
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ if use doc ; then
+ local mpage
+ for mpage in $(find docs/man -type f -regextype grep -regex ".*\.[[:digit:]]$") ; do
+ doman ${mpage}
+ done
+ fi
+ else
+ doman docs/man/man{1/*.1,3/*.3}
+ fi
+
+ find "${D}" -type f -name '*.la' -delete || die
+ rm "${ED}"/usr/bin/${PN}_noinstall || die
+}