summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-10 13:52:56 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-10 20:16:28 +0200
commit5baeb5f11e5cf3b93807dcab2a61ef26d93b11ca (patch)
tree0e58212afae26e0e51d5b33ca1f19928887f8fc8 /net-misc
parentprofiles/alpha: mask sci-visualization/gnuplot[amos] (diff)
downloadgentoo-5baeb5f11e5cf3b93807dcab2a61ef26d93b11ca.tar.gz
gentoo-5baeb5f11e5cf3b93807dcab2a61ef26d93b11ca.tar.bz2
gentoo-5baeb5f11e5cf3b93807dcab2a61ef26d93b11ca.zip
net-misc/gallery-dl: bump to 1.27.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.27.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 0375284ff3a1..35a922ca6353 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.27.1.gh.tar.gz 686087 BLAKE2B c80f37d314671637f435957abf9d79d01d421e48c89e90a3290e6fbf6e32f89d4b7495deeaf2ce0528750b65d4b404108fe78bc42f0e39dda4bcfd4267aa9dff SHA512 d3243bd23e7a743d98b9745d78b653546a49a97dd8468b60014fa6ba74071de8057c8b479dc3d74854b4c194034b027fe15bc530a60dea34dcc6221b105c285c
DIST gallery-dl-1.27.2.gh.tar.gz 698780 BLAKE2B 38b2506f46aa4fc03cc36844c8517dfb706b0da81de3bc33f303b87982dedf617b5e91f9e6e539874b8993f5c435114a4fdc0a11047312c3ece0132c076a3acb SHA512 f8510bfff48e75297a46b10f82f6f8457bd88e21fe79ed702fa165095ca649c07caa1c161b3350f3148837063e1fb5d780da00437f91a58efa68da02cfb05171
+DIST gallery-dl-1.27.3.gh.tar.gz 699804 BLAKE2B e1ded03fe94abcc442f4010e7e4cf51fbe1724543544761ccd318e61eb33146dbf25229d50123b9d0018b30dc6bffb895b022b61f6f5937dd77ea85f689206f2 SHA512 3fdee99af361364f7f1a207378c07efc24b3090f721da1dca3391972bdac4f31823e6711ac69ca6afca8de23fe276758af910179d511f739ec43b4408bbab6e6
diff --git a/net-misc/gallery-dl/gallery-dl-1.27.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.27.3.ebuild
new file mode 100644
index 000000000000..fea34fbde450
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.27.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Tests against real servers, some tests always fail and some are subject to change.
+ rm test/test_results.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_compile_all() {
+ emake PYTHON="${EPYTHON}" data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}