summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-11 20:33:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-11 20:35:04 +0200
commit60363ab10d385585037a43e4c4cb764d7df97e3d (patch)
tree25646fbbe0a9122c69c628cb1b625e8471adfde6 /net-misc
parentnet-misc/autoupnp: Remove old (diff)
downloadgentoo-60363ab10d385585037a43e4c4cb764d7df97e3d.tar.gz
gentoo-60363ab10d385585037a43e4c4cb764d7df97e3d.tar.bz2
gentoo-60363ab10d385585037a43e4c4cb764d7df97e3d.zip
net-misc/autoupnp: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/autoupnp/Manifest1
-rw-r--r--net-misc/autoupnp/autoupnp-0.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/autoupnp/Manifest b/net-misc/autoupnp/Manifest
index c9eac0b07a43..b42411cbe095 100644
--- a/net-misc/autoupnp/Manifest
+++ b/net-misc/autoupnp/Manifest
@@ -1 +1,2 @@
DIST autoupnp-0.5.0.tar.gz 7402 BLAKE2B b6de76a45e6811e57cfb15bf41d3305ad4e8ed9b1459270426724b016d33a9a398bae5bca4d3d87360d712614fcad0fa5d8571db88ce632afd43220539ba992d SHA512 0118b20fdb225673348c3ba469bfde6c37e79fba42e7dbf7bca6a0c25dd9f853b0ee73860c5dbb8165e97125cb71b2794d4e88ece0a1155c85f4c83390131dbc
+DIST autoupnp-0.5.1.tar.gz 14091 BLAKE2B 0df03b00dbf6623512c4598b7a9d9222e01317cbeba04006bec00f071ae1397986358fa2af5af38c712648e31ad7c89e81a32d73fcd2be332e75630a86f03826 SHA512 6d5d34dbb008f3be979c2692b16cc1d45a8b3062ef9fd60c268bb26a066f898e974301157e8d7fdcef7d279804504b4d2703bc09f83c8cc1173529673febf10a
diff --git a/net-misc/autoupnp/autoupnp-0.5.1.ebuild b/net-misc/autoupnp/autoupnp-0.5.1.ebuild
new file mode 100644
index 000000000000..511f1373b8e6
--- /dev/null
+++ b/net-misc/autoupnp/autoupnp-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Automatic open port forwarder using UPnP"
+HOMEPAGE="https://github.com/projg2/autoupnp/"
+SRC_URI="
+ https://github.com/projg2/autoupnp/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-libs/miniupnpc:0=
+ libnotify? ( x11-libs/libtinynotify:0= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature libnotify)
+ )
+ meson_src_configure
+}