summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-03-23 07:32:32 +0000
committerMatthew Smith <matthew@gentoo.org>2024-03-23 07:36:25 +0000
commit9577efa11cca713f2e5b7e80ab07cb37365fba19 (patch)
tree2927162dd1a607d94021c81ef964459cec685c75 /net-misc
parentgui-libs/gtk-layer-shell: enable py3.12 (diff)
downloadgentoo-9577efa11cca713f2e5b7e80ab07cb37365fba19.tar.gz
gentoo-9577efa11cca713f2e5b7e80ab07cb37365fba19.tar.bz2
gentoo-9577efa11cca713f2e5b7e80ab07cb37365fba19.zip
net-misc/xmrig: stop filtering -D_FORTIFY_SOURCE=3
Fixed upstream in commit f6c50b5393. Bug: https://bugs.gentoo.org/913420 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/xmrig/xmrig-9999.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-misc/xmrig/xmrig-9999.ebuild b/net-misc/xmrig/xmrig-9999.ebuild
index a36872e00718..2061563b6ac5 100644
--- a/net-misc/xmrig/xmrig-9999.ebuild
+++ b/net-misc/xmrig/xmrig-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake flag-o-matic systemd toolchain-funcs
+inherit cmake systemd
DESCRIPTION="RandomX, CryptoNight, KawPow, AstroBWT, and Argon2 CPU/GPU miner"
HOMEPAGE="https://xmrig.com https://github.com/xmrig/xmrig"
@@ -44,13 +44,6 @@ src_prepare() {
}
src_configure() {
- # JIT broken with FORTIFY_SOURCE=3
- # Bug #913420
- if tc-enables-fortify-source; then
- filter-flags -D_FORTIFY_SOURCE=3
- append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
- fi
-
local mycmakeargs=(
-DWITH_SSE4_1=$(usex cpu_flags_x86_sse4_1)
-DWITH_HWLOC=$(usex hwloc)