summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-19 01:07:41 -0500
committerSam James <sam@gentoo.org>2024-02-19 06:16:02 +0000
commite6268410df9427a59a9a4f08a0a10f7139f5d3a4 (patch)
treeb78cae96e2833d2fe40aa7dada84a1e212d8f78e /net-misc
parentnet-misc/openssh: remove pointless USE=X (diff)
downloadgentoo-e6268410df9427a59a9a4f08a0a10f7139f5d3a4.tar.gz
gentoo-e6268410df9427a59a9a4f08a0a10f7139f5d3a4.tar.bz2
gentoo-e6268410df9427a59a9a4f08a0a10f7139f5d3a4.zip
net-misc/openssh: use an officially supported approach to overriding xauth
Instead of patching out a header file, use the ./configure option dedicated for this purpose. It has the side effect of correctly sed'ing out config files / manpages with the updated location. When not explicitly passed, the builtin default is used as a fallback, but when USE=X, portage as an implementation detail guarantees that xauth will be installed before openssh is compiled. ... as long as you don't use --buildpkg. So, "probably" if you used USE=X the paths were correct, but: - this is overall a poor approach to reliability - it misses the point of also overriding the path when USE="-X" - we just removed the USE flag and the RDEPEND Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/openssh-9.6_p1-r3.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/net-misc/openssh/openssh-9.6_p1-r3.ebuild b/net-misc/openssh/openssh-9.6_p1-r3.ebuild
index 164c30ecc6c8..3876e99bb31c 100644
--- a/net-misc/openssh/openssh-9.6_p1-r3.ebuild
+++ b/net-misc/openssh/openssh-9.6_p1-r3.ebuild
@@ -128,10 +128,6 @@ pkg_pretend() {
}
src_prepare() {
- sed -i \
- -e "/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:${EPREFIX}/usr/bin/xauth:" \
- pathnames.h || die
-
# don't break .ssh/authorized_keys2 for fun
sed -i '/^AuthorizedKeysFile/s:^:#:' sshd_config || die
@@ -185,6 +181,8 @@ src_configure() {
--datadir="${EPREFIX}"/usr/share/openssh
--with-privsep-path="${EPREFIX}"/var/empty
--with-privsep-user=sshd
+ # optional at runtime; guarantee a known path
+ --with-xauth="${EPREFIX}"/usr/bin/xauth
# --with-hardening adds the following in addition to flags we
# already set in our toolchain: