summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2024-10-02 09:13:22 -0500
committerBen Kohler <bkohler@gentoo.org>2024-10-02 10:10:18 -0500
commite70547e47cb225b820354926cf9e72291c69b984 (patch)
tree0cd2f6c5adfbae5b3335b40ecd010bd1283f91be /net-misc
parentmedia-libs/opencv: Stabilize 4.9.0-r2 arm64, #939513 (diff)
downloadgentoo-e70547e47cb225b820354926cf9e72291c69b984.tar.gz
gentoo-e70547e47cb225b820354926cf9e72291c69b984.tar.bz2
gentoo-e70547e47cb225b820354926cf9e72291c69b984.zip
net-misc/dropbox: add 209.4.3647
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dropbox/Manifest1
-rw-r--r--net-misc/dropbox/dropbox-209.4.3647.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/net-misc/dropbox/Manifest b/net-misc/dropbox/Manifest
index b5e7f0de497b..c923a247e6a3 100644
--- a/net-misc/dropbox/Manifest
+++ b/net-misc/dropbox/Manifest
@@ -4,3 +4,4 @@ DIST dropbox-lnx.x86_64-205.4.5765.tar.gz 116601880 BLAKE2B 40fbef3634736e4350d7
DIST dropbox-lnx.x86_64-206.4.6506.tar.gz 116749927 BLAKE2B 231172bf0e51e6a316b76f21043258f99e3f771a241983848f0551db60189a624239e9cdd3110128d499028203d3d4511026da91c371da4ba73c6046ae2ad1b5 SHA512 80dfbefe898819f5880433aa87c7bdce52555c59173c01eb4dc464f12805aa14ea4d2f0dbcd31731d694f6151c3ec14f9e62db1b6ab35d4fdac3cefabd2660aa
DIST dropbox-lnx.x86_64-207.4.5821.tar.gz 116938187 BLAKE2B 4179a1f97e3ff7322aa0ceb5540fbdca57cb5119d18d63b82a0aff2e061376e68544f6a4c4e44197df4986a60f7478bb7528a1ab98540b6a865e8bef7282bdaa SHA512 b10584a4b8ac91893960dcc65c9986811800d43baeede5e222baf323941f5e7f026b1b2937ecbc3086b8cce9ccb9858de35fa0f980060c36badf8ee0e0caad9b
DIST dropbox-lnx.x86_64-208.4.5824.tar.gz 117271633 BLAKE2B 2783523510879a812c8020425bb0606c0e04523fe75d098a34e2be019430e18ee0d28e259b192e88174121199a996a18b74b3bd6edd15c6c16cf7e099bda1f15 SHA512 3e747b4b38a64a42cdfbd526b154401f86d662fdff04b684c287145a4069a5cf660033f97f58033e9fb60d29f038634166a815893daa5fc42bc76a2c07b45372
+DIST dropbox-lnx.x86_64-209.4.3647.tar.gz 117386225 BLAKE2B a8253fab39be528695f6f2e28a597862a32458f49cfc46c4a28e44e05e08e65e70bdef117cbd4679b3fbb9eb06d018f0c328a96b55b056d4ff334ceba9b20052 SHA512 2aee719f10c58e4cc106dd2dacec9673e1d9bb614e39f20ebdafd5f558cf61d5dbb311f73fd6f1f8fd93b9a68664e5f6b56a7c768457684e61740063ba013ad0
diff --git a/net-misc/dropbox/dropbox-209.4.3647.ebuild b/net-misc/dropbox/dropbox-209.4.3647.ebuild
new file mode 100644
index 000000000000..9aafe425d4d6
--- /dev/null
+++ b/net-misc/dropbox/dropbox-209.4.3647.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils systemd xdg
+
+DESCRIPTION="Dropbox daemon (pretends to be GUI-less)"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="
+ https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-${PV}.tar.gz
+ https://uxwing.com/wp-content/themes/uxwing/download/brands-and-social-media/dropbox-icon.svg
+"
+
+LICENSE="BSD-2 CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="selinux X"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/.*"
+QA_EXECSTACK="opt/dropbox/dropbox"
+
+BDEPEND="dev-util/patchelf"
+
+# Be sure to have GLIBCXX_3.4.9, #393125
+RDEPEND="
+ X? (
+ x11-themes/hicolor-icon-theme
+ )
+ selinux? ( sec-policy/selinux-dropbox )
+ app-arch/bzip2
+ dev-libs/glib:2
+ dev-libs/libffi-compat:6
+ media-libs/fontconfig
+ media-libs/freetype
+ net-misc/wget
+ sys-libs/zlib
+ sys-libs/ncurses-compat:5
+ virtual/opengl
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libxcb
+"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${S}" || die
+ mv "${WORKDIR}"/.dropbox-dist/* "${S}" || die
+ mv "${S}"/dropbox-lnx.*-${PV}/* "${S}" || die
+ rmdir "${S}"/dropbox-lnx.*-${PV}/ || die
+ rmdir .dropbox-dist || die
+}
+
+src_prepare() {
+ default
+ # we supply all of these in RDEPEND
+ rm -vf libGL.so.1 libX11* libffi.so.6 || die
+ # some of these do not appear to be used
+ rm -vf libQt5{OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets}.so.5 \
+ PyQt5.QtPrintSupport.* PyQt5.QtQml.* PyQt5.QtQuick.* \
+ wmctrl libdrm.so.2 libpopt.so.0 || die
+ if use X ; then
+ mv images/hicolor/16x16/status "${T}" || die
+ else
+ rm -vrf images || die
+ fi
+ patchelf --set-rpath '$ORIGIN' \
+ apex._apex.*.so \
+ nucleus_python.*.so \
+ tprt.*.so \
+ || die
+ pax-mark cm dropbox
+ mv README ACKNOWLEDGEMENTS "${T}" || die
+}
+
+src_install() {
+ local targetdir="/opt/dropbox"
+
+ insinto "${targetdir}"
+ doins -r *
+ fperms a+x "${targetdir}"/{dropbox,dropboxd}
+ dosym "${targetdir}/dropboxd" "/opt/bin/dropbox"
+
+ if use X; then
+ doicon -s 16 -c status "${T}"/status
+ newicon -s scalable "${DISTDIR}/dropbox-icon.svg" dropbox.svg
+ fi
+
+ make_desktop_entry "${PN}" "Dropbox" "dropbox"
+
+ newinitd "${FILESDIR}"/dropbox.initd dropbox
+ newconfd "${FILESDIR}"/dropbox.conf dropbox
+ systemd_newunit "${FILESDIR}"/dropbox_at.service-r2 "dropbox@.service"
+
+ dodoc "${T}"/{README,ACKNOWLEDGEMENTS}
+}
+
+pkg_postinst() {
+ einfo "Warning: while running, dropbox may attempt to autoupdate itself in"
+ einfo " your user's home directory. To prevent this, run the following as"
+ einfo " each user who will run dropbox:"
+ einfo ""
+ einfo "install -dm0 ~/.dropbox-dist"
+}