summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-17 22:38:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-17 22:40:56 +0100
commitf425ba589eb34406c8bff2c26939b108ee8169c5 (patch)
treeb59e53628ec34f5b4b5d1aa8e5e59db9f83a809d /net-misc
parentkde-apps/kaccounts-providers: drop 23.08.4-r2 (diff)
downloadgentoo-f425ba589eb34406c8bff2c26939b108ee8169c5.tar.gz
gentoo-f425ba589eb34406c8bff2c26939b108ee8169c5.tar.bz2
gentoo-f425ba589eb34406c8bff2c26939b108ee8169c5.zip
net-misc/smb4k: Bundle net-libs/kdsoap-ws-discovery-client...
Upstream has not yet finished porting to KF6/Qt6 and downstream package is already broken if a Qt6-based net-libs/kdsoap-ws-discovery-client is installed. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/smb4k/Manifest1
-rw-r--r--net-misc/smb4k/smb4k-3.2.5-r2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-misc/smb4k/Manifest b/net-misc/smb4k/Manifest
index d96bb2c7ef4f..5dab83953334 100644
--- a/net-misc/smb4k/Manifest
+++ b/net-misc/smb4k/Manifest
@@ -1 +1,2 @@
+DIST smb4k-3.2.5-bundled-kdsoap-ws-discovery-client.patch.xz 33212 BLAKE2B 774f56888ff29da7bbe9f94b74838d628052520b3c5f97e52d4f3b3dd20c0207d1e706e398b24a54c7a03cc3b9c5693c70e18f4418bfd9c83d8e3ce48cd19fe9 SHA512 004ebf52194a2801c01429990b00ada1b7e2850d1087d3efacf29542cac6a9bb351181ff8ef6713550279d9c5c2f415dcdfba847ef5c848a564b2454e6c05e81
DIST smb4k-3.2.5.tar.xz 4314812 BLAKE2B 9c5ca6f3d9607be1e5673f7d32a8dc5f191045ccc5607a4ccd9d48d07fc698278db5bbe5e8ffcc4fa9a1f390d52e7ebb877bc01146754873af5d3c266aad16d2 SHA512 6273c9701cf3d65f9b1d7ce0cbe929dc8f422b6a7a308f0b3c4c08e30acf2d189bc1ef4f960dad25aaf71b38b29ce6c41ba8adf50f0bb139e25a0d65a8e67a28
diff --git a/net-misc/smb4k/smb4k-3.2.5-r2.ebuild b/net-misc/smb4k/smb4k-3.2.5-r2.ebuild
new file mode 100644
index 000000000000..999148f34306
--- /dev/null
+++ b/net-misc/smb4k/smb4k-3.2.5-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm kde.org
+
+DESCRIPTION="Advanced network neighborhood browser"
+HOMEPAGE="https://apps.kde.org/smb4k/
+https://sourceforge.net/p/smb4k/home/Home/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~asturm/distfiles/${PN}-3.2.5-bundled-kdsoap-ws-discovery-client.patch.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="5"
+IUSE="+discovery plasma"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ net-fs/samba[cups]
+ discovery? (
+ net-libs/kdsoap:=[qt5(+)]
+ <net-libs/kdsoap-ws-discovery-client-0.3.0
+ )
+"
+RDEPEND="${DEPEND}
+ plasma? (
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-plasma/libplasma-${KFMIN}:5
+ )
+"
+
+PATCHES=(
+ "${WORKDIR}/${PN}-3.2.5-bundled-kdsoap-ws-discovery-client.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DSMB4K_WITH_WS_DISCOVERY=$(usex discovery)
+ -DSMB4K_INSTALL_PLASMOID=$(usex plasma)
+ )
+
+ use discovery && mycmakeargs+=(
+ # do not attempt to find now Qt6-based system version
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDSoapWSDiscoveryClient=ON
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "Users of Samba 4.7 and above please note that for the time being,"
+ elog "the following setting has to be added to or changed in the [global]"
+ elog "section of the smb.conf file:"
+ elog
+ elog "[global]"
+ elog "client max protocol = NT1"
+}