summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-03-29 22:38:36 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2023-03-29 22:50:58 +0200
commit611ec1c78a9033655eaf5cdcef686f1b4acce3af (patch)
tree170afca77e877ef65a342757bd1a2b844c69106e /net-p2p
parentnet-p2p/nicotine+: drop old. (diff)
downloadgentoo-611ec1c78a9033655eaf5cdcef686f1b4acce3af.tar.gz
gentoo-611ec1c78a9033655eaf5cdcef686f1b4acce3af.tar.bz2
gentoo-611ec1c78a9033655eaf5cdcef686f1b4acce3af.zip
net-p2p/nicotine+: 3.2.9 version bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/Manifest1
-rw-r--r--net-p2p/nicotine+/nicotine+-3.2.9.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/nicotine+/Manifest b/net-p2p/nicotine+/Manifest
index a43e978a7c44..662641e950a2 100644
--- a/net-p2p/nicotine+/Manifest
+++ b/net-p2p/nicotine+/Manifest
@@ -1 +1,2 @@
DIST nicotine+-3.2.8.tar.gz 2984416 BLAKE2B 8ca996e67a296535a158d1929579c4f479630bf4b666b53e91939fd61dcac90de657bfccd30521da9cc4468f3beecf1be433790ca711c67d0cf6d1e0a901be90 SHA512 92298b97ce34d713b0a4626602757a9215b57a0c3ac00c2845ff66597f0a361243f47c8abf3e8548f9f8c1829e56eb036e202242340bf268bf008b6ad6d016a5
+DIST nicotine+-3.2.9.tar.gz 2985424 BLAKE2B 1768d9f13ee15593661997ac0ad49c6c2d3aead685f83b86ae0ca05615f5fda04ea3abd3137a595d8457ef9643c4fd77adb47a76417b90d6c876bf55c56c4b31 SHA512 bc828bf8e6b194b23df8c7cce900704b918b71669ff9e0cf17b2c954838e265cc074dcb54e0abbcf563b19f10cf3199cc1980771b57e0af613ef2eed2ee4a3a8
diff --git a/net-p2p/nicotine+/nicotine+-3.2.9.ebuild b/net-p2p/nicotine+/nicotine+-3.2.9.ebuild
new file mode 100644
index 000000000000..4b5e695768b5
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-3.2.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="https://github.com/Nicotine-Plus/nicotine-plus"
+SRC_URI="https://github.com/Nicotine-Plus/nicotine-plus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ ${DEPEND}
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nicotine-plus-${PV}"
+
+EPYTEST_IGNORE=(
+ "test/integration/test_startup.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}