summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-03 10:17:22 +0100
committerSam James <sam@gentoo.org>2023-05-03 10:17:29 +0100
commit0f016579324f87d60297badd355a7eb9978e1209 (patch)
tree3d4348fd9cd92787c947ebece485721ad49e8976 /net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r2.ebuild
parentnet-misc/nextcloud-client: reformat SRC_URI (diff)
downloadgentoo-0f016579324f87d60297badd355a7eb9978e1209.tar.gz
gentoo-0f016579324f87d60297badd355a7eb9978e1209.tar.bz2
gentoo-0f016579324f87d60297badd355a7eb9978e1209.zip
net-vpn/protonvpn-cli: add missing jinja2 dep
Reported by cihancan on IRC. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r2.ebuild')
-rw-r--r--net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r2.ebuild b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r2.ebuild
new file mode 100644
index 000000000000..14149fe874e3
--- /dev/null
+++ b/net-vpn/protonvpn-cli/protonvpn-cli-2.2.11-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A VPN command-line tool from protonvpn - python rewrite"
+HOMEPAGE="https://protonvpn.com https://github.com/ProtonVPN/protonvpn-cli-ng"
+SRC_URI="https://github.com/ProtonVPN/linux-cli-community/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pythondialog:0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ net-vpn/openvpn
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/linux-cli-community-${PV}"
+
+DOCS=( CHANGELOG.md README.md USAGE.md )