summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-05-27 00:41:26 +0200
committerJohannes Huber <johu@gentoo.org>2018-05-27 00:41:47 +0200
commit31becc0e7149c4cb5da347ed64698482c669a46a (patch)
tree135651ac9bfbf295330c48ad02b3e938245e0bee /net-vpn
parentnet-wireless/gnuradio: [QA] Add call to cmake-utils_src_prepare (diff)
downloadgentoo-31becc0e7149c4cb5da347ed64698482c669a46a.tar.gz
gentoo-31becc0e7149c4cb5da347ed64698482c669a46a.tar.bz2
gentoo-31becc0e7149c4cb5da347ed64698482c669a46a.zip
net-vpn/openfortivpn: Version bump 1.7.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index f5b9246e362f..5dec0ccaf0d7 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1 +1,2 @@
DIST openfortivpn-1.6.0.tar.gz 55606 BLAKE2B 649ca2a8112313fc7b63d89867efe33c4cf8e75cb4c2f7f19839e1f569ac04e3ace841b17ac0e7aa9b51a7e6d9b1f7910925761d5052cac6ef5aec1e257b93bc SHA512 547dca62022f56271717191a10a645b8a1c554568536f0695ef73d8c2883926e957dc070570648ed672786374a01b110de34b4ea19c4ae8cb2e3657c27716c69
+DIST openfortivpn-1.7.0.tar.gz 60073 BLAKE2B 422e21daa4ee340009f9e1d660f12b4cc392e2c9694dc24cd2912c89996959907c2ea08fa3bfd11ea82c3984575f1cd1f59d671a7b4188e50ba1a9bbf77f9977 SHA512 60bf57a78e228f3f2f497f5b537abe25eb98a6fb8c41b521acf2e2182ac2c0ca12202a8c4e8d87cd230b0e35d31f4ae97f7137247b53e0c574bec195de0f4275
diff --git a/net-vpn/openfortivpn/openfortivpn-1.7.0.ebuild b/net-vpn/openfortivpn/openfortivpn-1.7.0.ebuild
new file mode 100644
index 000000000000..bfc317510e66
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info
+
+DESCRIPTION="A Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND="
+ net-dialup/ppp
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}