summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/eugene/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/eugene/files')
-rw-r--r--sci-biology/eugene/files/eugene-3.6-overflow.patch13
-rw-r--r--sci-biology/eugene/files/eugene-3.6-plugins.patch43
-rw-r--r--sci-biology/eugene/files/eugene-4.1-format-security.patch16
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-biology/eugene/files/eugene-3.6-overflow.patch b/sci-biology/eugene/files/eugene-3.6-overflow.patch
new file mode 100644
index 000000000000..7222530ad771
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-overflow.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=336607
+
+--- eugene-3.6/src/Sensor.cc
++++ eugene-3.6/src/Sensor.cc
+@@ -224,7 +224,7 @@
+ //--------------------------
+ void Signals :: PrintS ()
+ {
+- char t[7];
++ char t[10];
+ char s = '+';
+
+ switch (type) {
diff --git a/sci-biology/eugene/files/eugene-3.6-plugins.patch b/sci-biology/eugene/files/eugene-3.6-plugins.patch
new file mode 100644
index 000000000000..1e910a13d5b1
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-plugins.patch
@@ -0,0 +1,43 @@
+http://bugs.gentoo.org/show_bug.cgi?id=297536
+
+--- eugene-3.6/src/Makefile.am
++++ eugene-3.6/src/Makefile.am
+@@ -20,7 +20,7 @@
+
+ SUBDIRS = Parametrization GDIF . SensorPlugins
+
+-AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\"
++AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\" -DLIB_DIR=\"${libdir}\"
+ AM_CFLAGS =
+
+ bin_PROGRAMS = eugene
+--- eugene-3.6/src/MSensor.cc
++++ eugene-3.6/src/MSensor.cc
+@@ -97,7 +97,7 @@
+ std::string use_name;
+
+ if (!IsInitialized) {
+- PluginsDir = (std::string)PAR.getC("eugene_dir")+"/"+PLUGINS_DIR+"/";
++ PluginsDir = (std::string)LIB_DIR+"/eugene/"+PLUGINS_DIR+"/";
+
+ // On récupère les couples nom de sensor/priorité du .par
+ PAR.ResetIter();
+--- eugene-3.6/Makefile.am
++++ eugene-3.6/Makefile.am
+@@ -125,7 +125,7 @@
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Style
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Javascripts
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Images
+- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) -d $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models/WAM
+@@ -144,6 +144,6 @@
+ $(INSTALL) -m 644 $(srcdir)/web/Images/*jpg $(DESTDIR)/$(pkgdatadir)/web/Images
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.obo $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.par $(DESTDIR)/$(pkgdatadir)/cfg
+- $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) $(srcdir)/Procedures/Eval/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Eval
+ $(INSTALL) $(srcdir)/Procedures/Get/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Get
diff --git a/sci-biology/eugene/files/eugene-4.1-format-security.patch b/sci-biology/eugene/files/eugene-4.1-format-security.patch
new file mode 100644
index 000000000000..e6e4a6cc8bd7
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-4.1-format-security.patch
@@ -0,0 +1,16 @@
+ src/Hits.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Hits.cc b/src/Hits.cc
+index edfe178..b228be6 100755
+--- a/src/Hits.cc
++++ b/src/Hits.cc
+@@ -166,7 +166,7 @@ Hits* Hits::ReadFromFile(FILE* HitFile, int *NumHits, int level, int margin, int
+ while ((read=fscanf(HitFile,"%d %d %d %lf %d %s %d %d %as\n", &deb, &fin,
+ &poids, &evalue, &phase, HitId, &HSPDeb, &HSPFin,HSP)) >= 8)
+ {
+- if (HSP) fprintf(stderr,HSP);
++ if (HSP) fprintf(stderr, "%s", HSP);
+ if (phase < 0 && deb > fin)
+ {
+ int tmp = deb;