summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-04-03 18:14:04 +0200
committerDavid Seifert <soap@gentoo.org>2016-04-03 18:14:40 +0200
commitbed71574b0b2911b0e667931508bb5b069883b64 (patch)
treefb621ce2d0238528ecbea04964559888e9ec4c02 /sci-biology
parentnet-libs/mbedtls: move myself to fist maintainer (diff)
downloadgentoo-bed71574b0b2911b0e667931508bb5b069883b64.tar.gz
gentoo-bed71574b0b2911b0e667931508bb5b069883b64.tar.bz2
gentoo-bed71574b0b2911b0e667931508bb5b069883b64.zip
sci-biology/cufflinks: Depend only on sci-biology/samtools:0.1-legacy
Gentoo-Bug: 535716 * EAPI=6 * Updated boost in tree has fixed serialization for boost::shared_ptr * Build system is now orthogonal to sci-biology/samtools:0 and does not block updating to latest samtools Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/cufflinks/cufflinks-2.2.1-r2.ebuild39
-rw-r--r--sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch44
2 files changed, 83 insertions, 0 deletions
diff --git a/sci-biology/cufflinks/cufflinks-2.2.1-r2.ebuild b/sci-biology/cufflinks/cufflinks-2.2.1-r2.ebuild
new file mode 100644
index 000000000000..2ccac3099b0d
--- /dev/null
+++ b/sci-biology/cufflinks/cufflinks-2.2.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Transcript assembly and differential expression/regulation for RNA-Seq"
+HOMEPAGE="http://cufflinks.cbcb.umd.edu/"
+SRC_URI="http://cufflinks.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+IUSE="debug"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sci-biology/samtools:0.1-legacy
+ >=dev-libs/boost-1.59.0:=
+ dev-cpp/eigen:3"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-samtools-legacy.patch
+ "${FILESDIR}"/${P}-flags.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags eigen3)
+}
+
+src_configure() {
+ econf --disable-optim \
+ --with-boost-libdir="${EPREFIX}/usr/$(get_libdir)/" \
+ --with-bam="${EPREFIX}/usr/" \
+ $(use_enable debug)
+}
diff --git a/sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch b/sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch
new file mode 100644
index 000000000000..374ce519ef86
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-2.2.1-samtools-legacy.patch
@@ -0,0 +1,44 @@
+Modify the buildsystem to work with the legacy version of samtools,
+which can coexist with the most recent version of samtools.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=577854
+
+--- cufflinks-2.2.1/ax_bam.m4
++++ cufflinks-2.2.1/ax_bam.m4
+@@ -102,7 +102,7 @@
+
+ AC_LANG_PUSH(C++)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+- @%:@include <bam/bam.h>
++ @%:@include <bam-0.1-legacy/bam.h>
+ ]], [[
+ ]])],[
+ AC_MSG_RESULT(yes)
+@@ -171,7 +171,7 @@
+
+ AC_LANG_PUSH(C++)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+- @%:@include <bam/version.hpp>
++ @%:@include <bam-0.1-legacy/version.hpp>
+ ]], [[
+ ]])],[
+ AC_MSG_RESULT(yes)
+@@ -189,7 +189,7 @@
+ AC_MSG_NOTICE([Your bam libraries seem too old (version $_version).])
+ fi
+ else
+- BAM_LIB="-lbam"
++ BAM_LIB="-lbam-0.1-legacy"
+ AC_SUBST(BAM_CPPFLAGS)
+ AC_SUBST(BAM_LDFLAGS)
+ AC_SUBST(BAM_LIB)
+--- cufflinks-2.2.1/src/hits.h
++++ cufflinks-2.2.1/src/hits.h
+@@ -18,7 +18,7 @@
+
+ #include <boost/shared_ptr.hpp>
+
+-#include <bam/sam.h>
++#include <bam-0.1-legacy/sam.h>
+
+ #include "common.h"
+ #include "multireads.h"