summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-calculators/wcalc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-calculators/wcalc')
-rw-r--r--sci-calculators/wcalc/Manifest2
-rw-r--r--sci-calculators/wcalc/files/wcalc-2.3.1-parallel-build.patch11
-rw-r--r--sci-calculators/wcalc/metadata.xml17
-rw-r--r--sci-calculators/wcalc/wcalc-2.2.1.ebuild36
-rw-r--r--sci-calculators/wcalc/wcalc-2.4.ebuild34
5 files changed, 100 insertions, 0 deletions
diff --git a/sci-calculators/wcalc/Manifest b/sci-calculators/wcalc/Manifest
new file mode 100644
index 000000000000..b4b995a7c6cf
--- /dev/null
+++ b/sci-calculators/wcalc/Manifest
@@ -0,0 +1,2 @@
+DIST Wcalc-2.2.1.tar.bz2 214551 SHA256 82d3ed064c934a7791e8866f7ac25f2a600c2b435b5551101a2897b78d47a9af
+DIST wcalc-2.4.tar.bz2 361865 SHA256 aa2342078b9e75f821b0cc5d30f3434aa9cdf9af170e8a3e9af82286682be226
diff --git a/sci-calculators/wcalc/files/wcalc-2.3.1-parallel-build.patch b/sci-calculators/wcalc/files/wcalc-2.3.1-parallel-build.patch
new file mode 100644
index 000000000000..15ca95a2ae4a
--- /dev/null
+++ b/sci-calculators/wcalc/files/wcalc-2.3.1-parallel-build.patch
@@ -0,0 +1,11 @@
+diff -Naur Wcalc-2.3.1/Makefile.am Wcalc-2.3.1.new/Makefile.am
+--- Wcalc-2.3.1/Makefile.am 2007-02-25 21:09:18.000000000 -0500
++++ Wcalc-2.3.1.new/Makefile.am 2008-10-11 06:38:08.000000000 -0400
+@@ -1,6 +1,7 @@
+ bin_PROGRAMS = wcalc
+ AM_YFLAGS = -dt
+ #AM_LFLAGS = -w
++BUILT_SOURCES = parser.c
+ wcalc_SOURCES = calculator.h variables.h string_manip.h help.h parser.y \
+ string_manip.h historyManager.h files.h conversion.h \
+ scanner.l help.c calculator.c string_manip.c historyManager.c \
diff --git a/sci-calculators/wcalc/metadata.xml b/sci-calculators/wcalc/metadata.xml
new file mode 100644
index 000000000000..2f71e70ac84f
--- /dev/null
+++ b/sci-calculators/wcalc/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Wcalc is a very capable calculator. It has standard functions (sin,
+ asin, and sinh for example, in either radians or degrees), many
+ pre-defined constants (pi, e, c, etc.), support for using variables,
+ "active" variables, a command history, hex/octal/binary input and
+ output, unit conversions, embedded comments, and an expandable
+ expression entry field. It evaluates expressions using the standard
+ order of operations.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">w-calc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-calculators/wcalc/wcalc-2.2.1.ebuild b/sci-calculators/wcalc/wcalc-2.2.1.ebuild
new file mode 100644
index 000000000000..91fdfaac09e0
--- /dev/null
+++ b/sci-calculators/wcalc/wcalc-2.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A flexible command-line scientific calculator"
+HOMEPAGE="http://w-calc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/w-calc/Wcalc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="readline"
+
+DEPEND="
+ dev-libs/gmp
+ dev-libs/mpfr
+ readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/Wcalc-${PV}
+
+src_configure() {
+ econf $(use_with readline)
+}
+
+src_install() {
+ default
+
+ # Wcalc icons
+ newicon w.png wcalc.png
+ newicon Wred.png wcalc-red.png
+}
diff --git a/sci-calculators/wcalc/wcalc-2.4.ebuild b/sci-calculators/wcalc/wcalc-2.4.ebuild
new file mode 100644
index 000000000000..dd64c6d941fe
--- /dev/null
+++ b/sci-calculators/wcalc/wcalc-2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A flexible command-line scientific calculator"
+HOMEPAGE="http://w-calc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/w-calc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="readline"
+
+DEPEND="
+ dev-libs/gmp
+ dev-libs/mpfr
+ readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with readline)
+}
+
+src_install() {
+ default
+
+ # Wcalc icons
+ newicon w.png wcalc.png
+ newicon Wred.png wcalc-red.png
+}