summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/suitename
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/suitename')
-rw-r--r--sci-chemistry/suitename/Manifest1
-rw-r--r--sci-chemistry/suitename/metadata.xml22
-rw-r--r--sci-chemistry/suitename/suitename-0.3.070628.ebuild37
3 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/suitename/Manifest b/sci-chemistry/suitename/Manifest
new file mode 100644
index 000000000000..eac0c677a2bb
--- /dev/null
+++ b/sci-chemistry/suitename/Manifest
@@ -0,0 +1 @@
+DIST suitename.0.3.070628.src.tgz 29914 SHA256 5c2a709aa2d815b259475344aa2b982c157868eb9a7e5d6407b8f525f7e28c4c
diff --git a/sci-chemistry/suitename/metadata.xml b/sci-chemistry/suitename/metadata.xml
new file mode 100644
index 000000000000..06ac91e5fb9e
--- /dev/null
+++ b/sci-chemistry/suitename/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Suitename is a new C program that supports the ROC RNA Ontology Consortium
+consensus RNA backbone nomenclature and conformer-list development (see our RNA
+backbone rotamer section.
+From dihedral-angle input for a specific RNA structure (usually from Dangle),
+Suitename categorizes the RNA backbone geometry of each suite (the
+sugar-to-sugar version of a residue) either as an outlier ("!!") or as belonging
+to one of the 53 defined conformer bins. The output is either a
+one-line-per-suite report, or a linear conformer string (as shown below the
+image here) in one of several variant formats. Suitename is built into
+MolProbity, producing entries in the multi-criterion chart for an RNA model and
+also a suitestring file. The Suitename code is made available here for bulk or
+individual command-line use.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/suitename/suitename-0.3.070628.ebuild b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
new file mode 100644
index 000000000000..fb11e075c8d6
--- /dev/null
+++ b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="The ROC RNA Ontology Consortium consensus RNA backbone nomenclature and conformer-list development"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/suitename.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="richardson"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ tc-export CC
+ cp Makefile.linux Makefile || die
+ sed \
+ -e 's:cc:${CC}:g' \
+ -e "s:-o:${LDFLAGS} -o:g" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+}