summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/viewmol
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/viewmol')
-rw-r--r--sci-chemistry/viewmol/Manifest1
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch11
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-change-default-paths.patch68
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch20
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch23
-rw-r--r--sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch20
-rw-r--r--sci-chemistry/viewmol/metadata.xml8
-rw-r--r--sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild87
8 files changed, 238 insertions, 0 deletions
diff --git a/sci-chemistry/viewmol/Manifest b/sci-chemistry/viewmol/Manifest
new file mode 100644
index 000000000000..42b77e70d864
--- /dev/null
+++ b/sci-chemistry/viewmol/Manifest
@@ -0,0 +1 @@
+DIST viewmol-2.4.1.src.tgz 2229379 SHA256 dfed3eed6441d89c4bf2be1c13cbe263341c8880edf1742d446fc0f8f4a99e19
diff --git a/sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch b/sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch
new file mode 100644
index 000000000000..e5e22ffee893
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-change-default-path-to-usr.patch
@@ -0,0 +1,11 @@
+--- viewmol-2.4.1.orig/source/getrc.c 2004-10-20 05:54:35.000000000 -0700
++++ viewmol-2.4.1/source/getrc.c 2005-12-02 11:38:32.000000000 -0800
+@@ -87,7 +87,7 @@
+
+ static char viewmolpath[MAXLENLINE];
+
+-#define DEFAULTPATH "/usr/local/lib/viewmol"
++#define DEFAULTPATH "/usr/lib/viewmol"
+
+ int getrc(void)
+ {
diff --git a/sci-chemistry/viewmol/files/2.4.1-change-default-paths.patch b/sci-chemistry/viewmol/files/2.4.1-change-default-paths.patch
new file mode 100644
index 000000000000..16a3d7ef7e38
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-change-default-paths.patch
@@ -0,0 +1,68 @@
+diff --git a/source/getrc.c b/source/getrc.c
+index a39b436..c130096 100644
+--- a/source/getrc.c
++++ b/source/getrc.c
+@@ -87,7 +87,7 @@ extern XtAppContext app;
+
+ static char viewmolpath[MAXLENLINE];
+
+-#define DEFAULTPATH "/usr/local/lib/viewmol"
++#define DEFAULTPATH "@GENTOO_PORTAGE_EPREFIX@/usr/GENTOOLIBDIR/viewmol"
+
+ int getrc(void)
+ {
+diff --git a/source/install b/source/install
+index 580865b..f136af3 100755
+--- a/source/install
++++ b/source/install
+@@ -54,24 +54,27 @@ fi
+ cp $dirorig/viewmol $ROOT/bin
+ chmod 711 $ROOT/bin/viewmol
+
+-# install other files needed in $ROOT/lib/viewmol
+-if [ ! -d $ROOT/lib/viewmol/$dir ]
++# install other files needed in $ROOT/GENTOOLIBDIR/viewmol
++if [ ! -d $ROOT/GENTOOLIBDIR/viewmol/$dir ]
+ then
+- mkdir -p $ROOT/lib/viewmol/$dir
+- chmod 755 $ROOT/lib/viewmol/$dir
++ mkdir -p $ROOT/GENTOOLIBDIR/viewmol/$dir
++ chmod 755 $ROOT/GENTOOLIBDIR/viewmol/$dir
+ fi
+ cd $dirorig
+-cp tm bio readgamess readgauss readmopac readpdb $ROOT/lib/viewmol/$dir
+-chmod 711 $ROOT/lib/viewmol/$dir/*
++cp tm bio readgamess readgauss readmopac readpdb $ROOT/GENTOOLIBDIR/viewmol/$dir
++chmod 711 $ROOT/GENTOOLIBDIR/viewmol/$dir/*
+ cd ../..
+-cp readdmol readdmol.awk readgulp readpqs writecar writegauss.py writemol writetm $ROOT/lib/viewmol
+-chmod 755 $ROOT/lib/viewmol/*
+-cp -r doc examples locale scripts tests $ROOT/lib/viewmol
+-find $ROOT/lib/viewmol -type f -exec chmod a+r {} \;
+-find $ROOT/lib/viewmol -type d -exec chmod a+rx {} \;
+-sed 's/\/source//g' viewmolrc > $ROOT/lib/viewmol/viewmolrc
+-chmod -R 644 $ROOT/lib/viewmol/viewmolrc
+-if [ -d /usr/X11R6/lib/X11/app-defaults ]
++cp readdmol readdmol.awk readgulp readpqs writecar writegauss.py writemol writetm $ROOT/GENTOOLIBDIR/viewmol
++chmod 755 $ROOT/GENTOOLIBDIR/viewmol/*
++mkdir -p $ROOT/usr/share/viewmol $ROOT/usr/share/doc/GENTOODOCDIR/ $ROOT/GENTOOLIBDIR/viewmol/
++cp -r examples scripts tests $ROOT/usr/share/viewmol
++cp -r locale $ROOT/GENTOOLIBDIR/viewmol/
++cp -r doc/* examples scripts tests $ROOT/usr/share/doc/GENTOODOCDIR/
++find $ROOT/GENTOOLIBDIR/viewmol -type f -exec chmod a+r {} \;
++find $ROOT/GENTOOLIBDIR/viewmol -type d -exec chmod a+rx {} \;
++sed 's/\/source//g' viewmolrc > $ROOT/GENTOOLIBDIR/viewmol/viewmolrc
++chmod -R 644 $ROOT/GENTOOLIBDIR/viewmol/viewmolrc
++if [ -d $ROOT/X11R6/GENTOOLIBDIR/X11/app-defaults ]
+ then
+ locale=`echo $LANG | cut -c1-2`
+ if [ "$locale" = "en" ]
+@@ -82,6 +85,6 @@ then
+ # The C locale is defined by default for rpm builds, overwrite it
+ locale="en_US"
+ fi
+- cp locale/${locale}/Viewmol /usr/X11R6/lib/X11/app-defaults
+- chmod a+r /usr/X11R6/lib/X11/app-defaults/Viewmol
++ cp locale/${locale}/Viewmol ${ROOT}/X11R6/GENTOOLIBDIR/X11/app-defaults
++ chmod a+r ${ROOT}/X11R6/GENTOOLIBDIR/X11/app-defaults/Viewmol
+ fi
diff --git a/sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch b/sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch
new file mode 100644
index 000000000000..4f981a0fd1cb
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-look-for-python-in-right-place.patch
@@ -0,0 +1,20 @@
+--- viewmol-2.4.1.orig/source/getmachine 2004-08-29 08:04:09.000000000 -0700
++++ viewmol-2.4.1/source/getmachine 2005-12-02 11:19:36.000000000 -0800
+@@ -156,7 +158,7 @@
+ echo "PNGINCLUDE = $pnginclude" >> .config.$os
+
+ # Python
+- list=`find /usr -name Python.h -print 2> /dev/null`
++ list=`find /usr/include -name Python.h -print 2> /dev/null`
+ version=`(for i in $list
+ do
+ dir=\`dirname $i\`
+@@ -179,7 +181,7 @@
+ echo "PYTHONINCLUDE = $pythoninclude" >> .config.$os
+ if [ "$version" != "" ]
+ then
+- pythonlib=`dirname \`find /usr -name "lib${version}*.a" -print 2> /dev/null | grep "$version/"\``
++ pythonlib=`dirname \`find /usr/lib -name "lib${version}*.a" -print 2> /dev/null | grep "$version/"\``
+ else
+ givehint
+ echo -n "Please enter the name of the directory where the Python library can be found: "
diff --git a/sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch b/sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch
new file mode 100644
index 000000000000..c328e9cc79ab
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-remove-icc-check.patch
@@ -0,0 +1,23 @@
+diff -urN viewmol-2.4.1.orig/source/getmachine viewmol-2.4.1/source/getmachine
+--- viewmol-2.4.1.orig/source/getmachine 2004-08-29 08:04:09.000000000 -0700
++++ viewmol-2.4.1/source/getmachine 2005-12-02 09:30:49.000000000 -0800
+@@ -269,19 +269,11 @@
+ makedir
+ cat ../.config.$os > makefile
+ use_icc=`type icc 2> /dev/null`
+- if [ "$use_icc" = "" ]
+- then
+ findProcessor
+ echo 'COMPILER=gcc' >> makefile
+ echo "OPT=-O6 -mcpu=$processor -fomit-frame-pointer -ffast-math -malign-double" >> makefile
+ echo 'CFLAGS=-Wall -I/usr/X11R6/include -DLINUX -Wno-strict-aliasing' >> makefile
+ echo "LDFLAGS=$LINKFORSHARED" >> makefile
+- else
+- echo 'COMPILER=icc' >> makefile
+- echo 'OPT=-O2 -ipo' >> makefile
+- echo 'CFLAGS=-I/opt/intel/compiler50/ia32/include -I/usr/X11R6/include -DLINUX' >> makefile
+- echo "LDFLAGS=$LINKFORSHARED -ipo" >> makefile
+- fi
+ echo 'SCANDIR=' >> makefile
+ echo 'INCLUDE=$(TIFFINCLUDE) -I$(PNGINCLUDE) -I$(PYTHONINCLUDE)' >> makefile
+ echo 'LIBRARY=$(LIBTIFF) $(LIBPNG) -L$(LIBPYTHON)' >> makefile
diff --git a/sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch b/sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch
new file mode 100644
index 000000000000..c04da305c144
--- /dev/null
+++ b/sci-chemistry/viewmol/files/2.4.1-use-root-for-app-defaults.patch
@@ -0,0 +1,20 @@
+--- viewmol-2.4.1.orig/source/install 2004-10-09 08:38:31.000000000 -0700
++++ viewmol-2.4.1/source/install 2005-12-02 11:34:35.000000000 -0800
+@@ -71,7 +71,7 @@
+ find $ROOT/lib/viewmol -type d -exec chmod a+rx {} \;
+ sed 's/\/source//g' viewmolrc > $ROOT/lib/viewmol/viewmolrc
+ chmod -R 644 $ROOT/lib/viewmol/viewmolrc
+-if [ -d /usr/X11R6/lib/X11/app-defaults ]
++if [ -d $ROOT/X11R6/lib/X11/app-defaults ]
+ then
+ locale=`echo $LANG | cut -c1-2`
+ if [ "$locale" = "en" ]
+@@ -82,6 +82,6 @@
+ # The C locale is defined by default for rpm builds, overwrite it
+ locale="en_US"
+ fi
+- cp locale/${locale}/Viewmol /usr/X11R6/lib/X11/app-defaults
+- chmod a+r /usr/X11R6/lib/X11/app-defaults/Viewmol
++ cp locale/${locale}/Viewmol $ROOT/X11R6/lib/X11/app-defaults
++ chmod a+r $ROOT/X11R6/lib/X11/app-defaults/Viewmol
+ fi
diff --git a/sci-chemistry/viewmol/metadata.xml b/sci-chemistry/viewmol/metadata.xml
new file mode 100644
index 000000000000..c23d7012cd04
--- /dev/null
+++ b/sci-chemistry/viewmol/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <upstream>
+ <remote-id type="sourceforge">viewmol</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild b/sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild
new file mode 100644
index 000000000000..33fcaab73c3a
--- /dev/null
+++ b/sci-chemistry/viewmol/viewmol-2.4.1-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+
+inherit eutils multilib prefix python toolchain-funcs
+
+DESCRIPTION="Open-source graphical front end for computational chemistry programs"
+HOMEPAGE="http://viewmol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewmol/${P}.src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libpng
+ media-libs/tiff
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ >=x11-libs/motif-2.3:0"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+S="${WORKDIR}/${P}/source"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-remove-icc-check.patch \
+ "${FILESDIR}"/${PV}-change-default-paths.patch
+
+ eprefixify getrc.c
+ sed "s:GENTOOLIBDIR:$(get_libdir):g" \
+ -i install getrc.c || die
+ sed "s:GENTOODOCDIR:${PF}:g" -i install || die
+
+ LINKFORSHARED=$($(PYTHON) -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('LINKFORSHARED')")
+
+ mkdir $(uname -s) && cd $(uname -s)
+
+ cat >> .config.$(uname -s) <<- EOF
+ LIBTIFF = -L"${EPREFIX}/usr/$(get_libdir)"
+ TIFFINCLUDE = "${EPREFIX}/usr/include"
+ LIBPNG = -L"${EPREFIX}/usr/$(get_libdir)"
+ PNGINCLUDE = "${EPREFIX}/usr/include"
+ PYTHONVERSION = $(PYTHON)
+ PYTHONINCLUDE = "${EPREFIX}/$(python_get_includedir)"
+ PYTHONLIB = "${EPREFIX}/usr/$(get_libdir)"
+ COMPILER = $(tc-getCC)
+ CFLAGS = ${CFLAGS} -DLINUX
+ LDFLAGS = ${LDFLAGS} ${LINKFORSHARED}
+ SCANDIR=
+ INCLUDE=\$(TIFFINCLUDE) -I\$(PNGINCLUDE) -I\$(PYTHONINCLUDE)
+ LIBRARY=\$(LIBTIFF) \$(LIBPNG) -L\$(LIBPYTHON)
+ LIBS=-L"${EPREFIX}/usr/$(get_libdir)" $(python_get_library -l) -ltiff -lpng -lz -lGLU -lGL -L"${EPREFIX}/usr/X11R6/lib" -lXm -lXmu -lXp -lXi -lXext -lXt -lX11 -lpthread -lutil -ldl -lm
+ EOF
+
+ cp .config.$(uname -s) makefile
+ cat ../Makefile >> makefile
+}
+
+src_compile() {
+ pushd $(uname -s)
+ emake viewmol_ tm_ bio_ readgamess_ readgauss_ readmopac_ readpdb_ || die
+ popd
+ "${EPREFIX}"/bin/bash makeTranslations || die
+}
+
+src_install() {
+ ./install "${ED}"/usr || die
+ mv "${ED}"/usr/{usr/share,} || die
+ rm -rf "${ED}"/usr/usr
+}