summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-30 21:48:22 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-30 23:11:52 +0200
commitbb7946c448a325cf280c0c04c7362faed65f9b73 (patch)
treed96246fa5949253a9689f619b69af3455bbea0b9 /sci-chemistry
parentsci-biology/bowtie: enable py3.12 (diff)
downloadgentoo-bb7946c448a325cf280c0c04c7362faed65f9b73.tar.gz
gentoo-bb7946c448a325cf280c0c04c7362faed65f9b73.tar.bz2
gentoo-bb7946c448a325cf280c0c04c7362faed65f9b73.zip
sci-chemistry/propka: add 3.5.1
Closes: https://bugs.gentoo.org/929761 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/propka/Manifest1
-rw-r--r--sci-chemistry/propka/propka-3.5.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sci-chemistry/propka/Manifest b/sci-chemistry/propka/Manifest
index a3ae32cc089e..18e3621e2c6f 100644
--- a/sci-chemistry/propka/Manifest
+++ b/sci-chemistry/propka/Manifest
@@ -1 +1,2 @@
DIST propka-3.4.0.gh.tar.gz 363641 BLAKE2B 87f495ba69028593cf3ebf98ed33da0944f7a3833f2d08cae4f0a0b5cbe2f3a67e9812685b896a7d89c88ba25653861f135dbac53dc6df7af426a290bacb3d22 SHA512 2ce431c66374d0692acb7504661caa870ab6460ace3a6478f88c1d46a7bfcd82c748bf153a1ce2ea6d1611bc4bbf2351c4f5149f4578e5f8a9f9ec8385298fe9
+DIST propka-3.5.1.gh.tar.gz 376176 BLAKE2B ef4f5f51a6d08da566aa8dc4d2ec73ca028137031dbe49ca329589fe9ceb7cdda672cac755735a11bed79db1f31be5401b083239214177c2d459207ae998ae29 SHA512 3a9a7fd773700850f14c3ef1cc4ef7614242ea1191001fdca6afd44953486f208cbc067b84752c89e97e82ef6bac5561907b2aeafbee80c4d83cbf3ab443aaa2
diff --git a/sci-chemistry/propka/propka-3.5.1.ebuild b/sci-chemistry/propka/propka-3.5.1.ebuild
new file mode 100644
index 000000000000..2c9eb2ee4f27
--- /dev/null
+++ b/sci-chemistry/propka/propka-3.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="pKa-value prediction of ionizable groups in protein and protein-ligand complexes"
+HOMEPAGE="https://github.com/jensengroup/propka"
+SRC_URI="https://github.com/jensengroup/propka/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install the tests
+ sed -e "/exclude/s:scripts:\', \'tests:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}