summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/geda-xgsch2pcb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/geda-xgsch2pcb')
-rw-r--r--sci-electronics/geda-xgsch2pcb/Manifest1
-rw-r--r--sci-electronics/geda-xgsch2pcb/files/0.1.3-python.patch31
-rw-r--r--sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r2.ebuild78
-rw-r--r--sci-electronics/geda-xgsch2pcb/metadata.xml15
4 files changed, 125 insertions, 0 deletions
diff --git a/sci-electronics/geda-xgsch2pcb/Manifest b/sci-electronics/geda-xgsch2pcb/Manifest
new file mode 100644
index 000000000000..3616b70419e9
--- /dev/null
+++ b/sci-electronics/geda-xgsch2pcb/Manifest
@@ -0,0 +1 @@
+DIST geda-xgsch2pcb-0.1.3.tar.gz 160225 SHA256 dec4201fca0579eb296260ff4edb9088855740995acd0b163319b1b2e0e7e471 SHA512 24d8c798be49a0aa09c12c97eb6d33e1bd5ccf1a866a8889dd04e3dd2035afd6b8799638d696691216df9d5c645922b8cfb5aadc1373d15c6ee62eec0f72b965 WHIRLPOOL 46c16216409c8051ea70cdaf0629509b6c167dc7bc71ced7882f0c4696f1ce9ebc7276b9d1ff189ee0e98317cd6bd08a16fd872698c7ff8a4764320b52381400
diff --git a/sci-electronics/geda-xgsch2pcb/files/0.1.3-python.patch b/sci-electronics/geda-xgsch2pcb/files/0.1.3-python.patch
new file mode 100644
index 000000000000..f06b2aff4a5f
--- /dev/null
+++ b/sci-electronics/geda-xgsch2pcb/files/0.1.3-python.patch
@@ -0,0 +1,31 @@
+diff --git a/Makefile.am b/Makefile.am
+index aa8e2d6..4193aac 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,7 +22,7 @@ SUBDIRS = po data
+
+ bin_SCRIPTS = xgsch2pcb
+
+-pkglib_PYTHON = lib/xgsch2pcb/pcbmanager.py \
++pkgpython_PYTHON = lib/xgsch2pcb/pcbmanager.py \
+ lib/xgsch2pcb/gsch2pcbproject.py \
+ lib/xgsch2pcb/gui.py \
+ lib/xgsch2pcb/new_project_gui.py \
+@@ -30,7 +30,7 @@ pkglib_PYTHON = lib/xgsch2pcb/pcbmanager.py \
+ lib/xgsch2pcb/templates.py \
+ lib/xgsch2pcb/funcs.py
+
+-nodist_pkglib_PYTHON = config.py
++nodist_pkgpython_PYTHON = config.py
+
+ INTLTOOL_FILES = intltool-extract.in \
+ intltool-merge.in \
+@@ -53,7 +53,7 @@ templatesdir = @templatesdir@
+ do_subst = sed -e 's,[@]prefix[@],$(prefix),g' \
+ -e 's,[@]PYTHON[@],$(PYTHON),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+- -e 's,[@]pkglibdir[@],$(pkglibdir),g' \
++ -e 's,[@]pkglibdir[@],$(pkgpythondir),g' \
+ -e 's,[@]templatesdir[@],$(templatesdir),g' \
+ -e 's,[@]PACKAGE[@],$(PACKAGE),g'
+
diff --git a/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r2.ebuild b/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..aff4c681fd89
--- /dev/null
+++ b/sci-electronics/geda-xgsch2pcb/geda-xgsch2pcb-0.1.3-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+WANT_AUTOCONF="2.5"
+PYTHON_DEPEND="2"
+
+inherit autotools eutils fdo-mime gnome2-utils python
+
+DESCRIPTION="A graphical front-end for the gschem -> pcb workflow"
+HOMEPAGE="http://www.gpleda.org"
+SRC_URI="http://geda.seul.org/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gnome nls"
+
+CDEPEND="
+ dev-python/pygtk:2
+ dev-python/pygobject:2
+ dev-python/dbus-python
+ sci-electronics/pcb[dbus]
+ sci-electronics/geda
+ nls? ( virtual/libintl )"
+
+RDEPEND="
+ ${CDEPEND}
+ sci-electronics/electronics-menu
+ gnome? ( dev-python/gnome-vfs-python )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/intltool
+ dev-lang/perl
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare(){
+ echo '#!/bin/sh' > py-compile
+ epatch "${FILESDIR}"/${PV}-python.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --disable-update-desktop-database \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ python_mod_cleanup ${PN}
+}
diff --git a/sci-electronics/geda-xgsch2pcb/metadata.xml b/sci-electronics/geda-xgsch2pcb/metadata.xml
new file mode 100644
index 000000000000..55a84c45251b
--- /dev/null
+++ b/sci-electronics/geda-xgsch2pcb/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ ``gsch2pcb`` is a command-line tool, part of the gEDA suite, which is used
+ to generate and update a PCB layout. It works with schematics created
+ by ``gschem``, part of the gEDA suite, and layouts created by ``pcb``, a
+ PCB layout system commonly used with gEDA.
+
+ ``xgsch2pcb`` provides an intuitive, user-friendly graphical interface to
+ ``gsch2pcb``.
+ </longdescription>
+</pkgmetadata>
+