summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2024-11-18 09:31:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2024-11-18 09:31:02 +0100
commit6dc7a6f57c7681f7dd669295adeb5dcbc15117f2 (patch)
tree9aa39e320fd6f59b5572f8534bfd93acd468f9cf /sci-electronics
parentsci-libs/pcl: add upstream patch for latest boost compat (diff)
downloadgentoo-6dc7a6f57c7681f7dd669295adeb5dcbc15117f2.tar.gz
gentoo-6dc7a6f57c7681f7dd669295adeb5dcbc15117f2.tar.bz2
gentoo-6dc7a6f57c7681f7dd669295adeb5dcbc15117f2.zip
sci-electronics/gazebo: upstream patch for boost 1.86 compat
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gazebo/files/boost186.patch23
-rw-r--r--sci-electronics/gazebo/gazebo-11.14.0.ebuild1
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/files/boost186.patch b/sci-electronics/gazebo/files/boost186.patch
new file mode 100644
index 000000000000..c34632d9b819
--- /dev/null
+++ b/sci-electronics/gazebo/files/boost186.patch
@@ -0,0 +1,23 @@
+From 0cc96de9cd128c8f2255f022f6e2b1bccc8512c4 Mon Sep 17 00:00:00 2001
+From: Tobias Fischer <info@tobiasfischer.info>
+Date: Sun, 25 Aug 2024 08:09:21 +1000
+Subject: [PATCH] Boost 1.86 compatibility
+
+Signed-off-by: Tobias Fischer <info@tobiasfischer.info>
+---
+ gazebo/common/CommonIface.hh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gazebo/common/CommonIface.hh b/gazebo/common/CommonIface.hh
+index 82606a8528..a38935250f 100644
+--- a/gazebo/common/CommonIface.hh
++++ b/gazebo/common/CommonIface.hh
+@@ -229,7 +229,7 @@ namespace gazebo
+ std::string common::get_sha1(const T &_buffer)
+ {
+ boost::uuids::detail::sha1 sha1;
+- unsigned int hash[5];
++ boost::uuids::detail::sha1::digest_type hash;
+ std::stringstream stream;
+
+ if (_buffer.size() == 0)
diff --git a/sci-electronics/gazebo/gazebo-11.14.0.ebuild b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
index 04caee69b302..3fda8329c57b 100644
--- a/sci-electronics/gazebo/gazebo-11.14.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
@@ -67,6 +67,7 @@ PATCHES=(
"${FILESDIR}/cmake.patch"
"${FILESDIR}/gv10.patch"
"${FILESDIR}/boost.patch"
+ "${FILESDIR}/boost186.patch"
)
src_configure() {