summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:15:41 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-08-01 15:15:41 +0200
commitf0966300dbbfea0b0e339982738d958bafb252dc (patch)
tree4e49380c01621579fbf3df8c5df1b935978e3e92 /sci-geosciences/folium
parentsci-libs/branca: Add to tree (diff)
downloadgentoo-f0966300dbbfea0b0e339982738d958bafb252dc.tar.gz
gentoo-f0966300dbbfea0b0e339982738d958bafb252dc.tar.bz2
gentoo-f0966300dbbfea0b0e339982738d958bafb252dc.zip
sci-geosciences/folium: add to tree
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-geosciences/folium')
-rw-r--r--sci-geosciences/folium/Manifest1
-rw-r--r--sci-geosciences/folium/files/folium-0.12.1-gentoo.patch14
-rw-r--r--sci-geosciences/folium/files/folium-0.12.1-scm.patch12
-rw-r--r--sci-geosciences/folium/folium-0.12.1.ebuild32
-rw-r--r--sci-geosciences/folium/metadata.xml18
5 files changed, 77 insertions, 0 deletions
diff --git a/sci-geosciences/folium/Manifest b/sci-geosciences/folium/Manifest
new file mode 100644
index 000000000000..696e7bd38655
--- /dev/null
+++ b/sci-geosciences/folium/Manifest
@@ -0,0 +1 @@
+DIST folium-0.12.1.tar.gz 20033236 BLAKE2B 00e9fb369be9300ca04f9ba3fed18ca28a4985111ccd358312570773b80906df292e14a6f4acbd8ea7686f1b807017f729ad918b3b025af321faf5d7686333db SHA512 b19d2180c36160a370e6ab5ccfacf74ba7b735610d43e69a5200529c776e9c11ee42f4f7fa1ee54621f52b0f2e1fc1f86bc9a146c4a924831b12578643a69616
diff --git a/sci-geosciences/folium/files/folium-0.12.1-gentoo.patch b/sci-geosciences/folium/files/folium-0.12.1-gentoo.patch
new file mode 100644
index 000000000000..e2fbf5f35e15
--- /dev/null
+++ b/sci-geosciences/folium/files/folium-0.12.1-gentoo.patch
@@ -0,0 +1,14 @@
+--- a/setup.cfg 2021-07-30 23:31:49.026429515 +0200
++++ b/setup.cfg 2021-07-30 23:32:04.638212109 +0200
+@@ -11,11 +11,6 @@
+ parentdir_prefix =
+
+ [tool:pytest]
+-flake8-max-line-length = 121
+-flake8-ignore =
+- docs/* ALL
+-select = C,E,F,W,B,B950
+-ignore = E203, E501, W503
+
+ [metadata]
+ description-file = README.md
diff --git a/sci-geosciences/folium/files/folium-0.12.1-scm.patch b/sci-geosciences/folium/files/folium-0.12.1-scm.patch
new file mode 100644
index 000000000000..78992bafa059
--- /dev/null
+++ b/sci-geosciences/folium/files/folium-0.12.1-scm.patch
@@ -0,0 +1,12 @@
+--- a/setup.py 2021-07-30 23:29:57.320896714 +0200
++++ b/setup.py 2021-07-30 23:30:05.608787963 +0200
+@@ -89,9 +89,4 @@
+ extras_require={"testing": ["pytest"]},
+ install_requires=install_requires,
+ zip_safe=False,
+- use_scm_version={
+- "write_to": "folium/_version.py",
+- "write_to_template": '__version__ = "{version}"',
+- "tag_regex": r"^(?P<prefix>v)?(?P<version>[^\+]+)(?P<suffix>.*)?$",
+- },
+ )
diff --git a/sci-geosciences/folium/folium-0.12.1.ebuild b/sci-geosciences/folium/folium-0.12.1.ebuild
new file mode 100644
index 000000000000..ef7a70a505ac
--- /dev/null
+++ b/sci-geosciences/folium/folium-0.12.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python Data, Leaflet.js Maps"
+HOMEPAGE="https://github.com/python-visualization/folium"
+SRC_URI="${HOMEPAGE}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-scm.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+RDEPEND="sci-libs/branca[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r tests/selenium || die
+ default
+}
diff --git a/sci-geosciences/folium/metadata.xml b/sci-geosciences/folium/metadata.xml
new file mode 100644
index 000000000000..4afe8241f01e
--- /dev/null
+++ b/sci-geosciences/folium/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python Data, Leaflet.js Maps
+ folium builds on the data wrangling strengths of the Python ecosystem
+ and the mapping strengths of the Leaflet.js library.
+ Manipulate your data in Python, then visualize it in a Leaflet map
+ via folium.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">python-visualization/folium</remote-id>
+ </upstream>
+</pkgmetadata>