summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-09-18 23:19:47 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-09-18 23:19:47 +0700
commit3f54768366733f56fa8fd78989e00d88f6554afd (patch)
treeb1e502eaae4a13251026b742d47cdf5154a91994 /sci-geosciences/qmapshack
parentapp-text/pdfjam: drop 2.08-r1 (diff)
downloadgentoo-3f54768366733f56fa8fd78989e00d88f6554afd.tar.gz
gentoo-3f54768366733f56fa8fd78989e00d88f6554afd.tar.bz2
gentoo-3f54768366733f56fa8fd78989e00d88f6554afd.zip
_p600: list of dependencies improved
Bug: https://bugs.gentoo.org/926676 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-geosciences/qmapshack')
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r1.ebuild b/sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r1.ebuild
new file mode 100644
index 000000000000..c884821ce0d6
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.17.1_p600-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://github.com/Maproom/qmapshack/wiki"
+COMMIT="1f009ac0be1d1c2a4c31aa1283f4009e88685d34"
+SRC_URI="https://github.com/kiozen/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-db/sqlite
+ >=dev-libs/quazip-1.3:0=[qt6]
+ dev-qt/qt5compat:6[icu,qml]
+ dev-qt/qtbase[dbus,gui,icu,network,opengl,sql,widgets,xml]
+ dev-qt/qttools:6[assistant,linguist,opengl,qdbus,qml,widgets,zstd]
+ dev-qt/qtwebengine:6[qml,widgets]
+ sci-geosciences/routino
+ sci-libs/alglib
+ sci-libs/gdal:=
+ sci-libs/proj:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}/html
+ cmake_src_install
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html || die "mv Qt help failed"
+ ewarn "An experimental Qt6 port"
+ ewarn "Translations and the help system are broken"
+ ewarn "Other bugs to https://github.com/Maproom/qmapshack/issues"
+}