summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-06-02 07:40:56 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-06-02 07:53:51 -0400
commit1c7a8d9e9a4342f577b902b2d87b8e3b8e5eebe6 (patch)
tree06b49ed18d3e8cd1fa81c8dcc3c668e56684ab28 /sci-libs/fplll
parentsci-libs/fplll: upstream bump (diff)
downloadgentoo-1c7a8d9e9a4342f577b902b2d87b8e3b8e5eebe6.tar.gz
gentoo-1c7a8d9e9a4342f577b902b2d87b8e3b8e5eebe6.tar.bz2
gentoo-1c7a8d9e9a4342f577b902b2d87b8e3b8e5eebe6.zip
sci-libs/fplll: fix bashism in the latest version's ./configure.
Pending upstream pull request: https://github.com/fplll/fplll/pull/491 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/files/fplll-5.4.2-with-qd-fix.patch27
-rw-r--r--sci-libs/fplll/fplll-5.4.2.ebuild11
2 files changed, 37 insertions, 1 deletions
diff --git a/sci-libs/fplll/files/fplll-5.4.2-with-qd-fix.patch b/sci-libs/fplll/files/fplll-5.4.2-with-qd-fix.patch
new file mode 100644
index 000000000000..73c9b4386fd1
--- /dev/null
+++ b/sci-libs/fplll/files/fplll-5.4.2-with-qd-fix.patch
@@ -0,0 +1,27 @@
+From 94010a8c4c93c6ba9520b7c26bb6cb36344a4bf9 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 1 Jun 2022 22:11:48 -0400
+Subject: [PATCH 1/1] configure.ac: fix bashism in --with-qd test.
+
+There's a double-equals test here that doesn't work properly when
+/bin/sh is not bash. We simply change it to single-equals.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0ccc4c4..ed0cd59 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,7 +104,7 @@ AS_IF([test -z "$with_qd"], [with_qd=yes])
+ # and libraries if that didn't work for some reason.
+ #
+ # We only show a warning if we cannot find libqd, it is optional but recommended
+-AS_IF([test "x$with_qd" == "xyes"], [
++AS_IF([test "x$with_qd" = "xyes"], [
+ PKG_CHECK_MODULES([LIBQD], [qd], [have_libqd="yes"], [
+ # fall back to manual search.
+ AC_SEARCH_LIBS(c_dd_add,
+--
+2.35.1
+
diff --git a/sci-libs/fplll/fplll-5.4.2.ebuild b/sci-libs/fplll/fplll-5.4.2.ebuild
index 01b12f0488b4..dc83e78f3551 100644
--- a/sci-libs/fplll/fplll-5.4.2.ebuild
+++ b/sci-libs/fplll/fplll-5.4.2.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
HOMEPAGE="https://github.com/fplll/fplll"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
@@ -18,6 +20,13 @@ DEPEND="dev-libs/gmp:0
qd? ( sci-libs/qd )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-with-qd-fix.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_with qd) \
@@ -26,5 +35,5 @@ src_configure() {
src_install() {
default
- find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}