summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2025-01-09 18:16:16 +0000
committerSam James <sam@gentoo.org>2025-01-10 00:29:17 +0000
commitd8505d5905735b93ae5f060b0382e10a19cf4023 (patch)
tree8be64930c0e31289b69695c8fcc3c8ff2670edcb /sci-libs/hipBLAS
parentdev-libs/rocr-runtime: fix compilation with gcc-15 (diff)
downloadgentoo-d8505d5905735b93ae5f060b0382e10a19cf4023.tar.gz
gentoo-d8505d5905735b93ae5f060b0382e10a19cf4023.tar.bz2
gentoo-d8505d5905735b93ae5f060b0382e10a19cf4023.zip
sci-libs/hipBLAS: fix compilation when git is not installed
Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/40074 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/hipBLAS')
-rw-r--r--sci-libs/hipBLAS/files/hipBLAS-6.3.0-no-git.patch18
-rw-r--r--sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild6
2 files changed, 23 insertions, 1 deletions
diff --git a/sci-libs/hipBLAS/files/hipBLAS-6.3.0-no-git.patch b/sci-libs/hipBLAS/files/hipBLAS-6.3.0-no-git.patch
new file mode 100644
index 000000000000..63fd25240505
--- /dev/null
+++ b/sci-libs/hipBLAS/files/hipBLAS-6.3.0-no-git.patch
@@ -0,0 +1,18 @@
+Git is not required and rev-parse does nothing for tarballs.
+--- a/library/CMakeLists.txt
++++ b/library/CMakeLists.txt
+@@ -44,14 +44,6 @@ if( BUILD_VERBOSE )
+ message( STATUS "\t==>CMAKE_EXE_LINKER link flags: " ${CMAKE_EXE_LINKER_FLAGS} )
+ endif( )
+
+-# Get the git hash of the hipBLAS branch
+-find_package(Git REQUIRED)
+-
+-execute_process(COMMAND "${GIT_EXECUTABLE}" rev-parse HEAD
+- WORKING_DIRECTORY ${CMAKE_CURRENT_LIST_DIR}
+- OUTPUT_VARIABLE GIT_HASH_HIPBLAS
+- OUTPUT_STRIP_TRAILING_WHITESPACE)
+-
+ set(hipblas_VERSION_COMMIT_ID "${GIT_HASH_HIPBLAS}")
+
+ # log build commits
diff --git a/sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild b/sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild
index c8659df1eeee..1faf7edbf78c 100644
--- a/sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild
+++ b/sci-libs/hipBLAS/hipBLAS-6.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.0-no-git.patch
+)
+
src_configure() {
# Note: hipcc is enforced; clang fails when libc++ is enabled
# with an error similar to https://github.com/boostorg/config/issues/392