summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libpdb++/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libpdb++/files')
-rw-r--r--sci-libs/libpdb++/files/040728-dynlib.patch12
-rw-r--r--sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch54
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/libpdb++/files/040728-dynlib.patch b/sci-libs/libpdb++/files/040728-dynlib.patch
new file mode 100644
index 000000000000..a9792afb52a8
--- /dev/null
+++ b/sci-libs/libpdb++/files/040728-dynlib.patch
@@ -0,0 +1,12 @@
+diff --git a/libpdb++/Makefile b/libpdb++/Makefile
+index bbf0778..286a638 100644
+--- a/libpdb++/Makefile
++++ b/libpdb++/Makefile
+@@ -32,6 +32,7 @@ install: $(LIBARCH)
+
+ $(LIBARCH): $(OBJS)
+ @echo "Loading $(LIBARCH) ... "
++ $(CXX) $(LDFLAGS) -shared -Wl,--soname,libpdb++.so.0 -o libpdb++.so.0.1 $(OBJS)
+ @ar cru $(LIBARCH) $(OBJS)
+ @$(RANLIB) $(LIBARCH)
+ @echo "done"
diff --git a/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch b/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch
new file mode 100644
index 000000000000..3600481f4c72
--- /dev/null
+++ b/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch
@@ -0,0 +1,54 @@
+ Makefile | 20 +++++++++++++-------
+ 1 file changed, 13 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index bbf0778..1dc6c62 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,22 +4,22 @@
+ # On System V machines, RANLIB should be ':'
+ #
+ SHELL = /bin/sh
+-RANLIB = :
++#RANLIB = :
+
+-CXX = gcc -felide-constructors
++CXX ?= g++
+ #CXX = CC
+
+ .SUFFIXES: .cc
+
+ .cc.o:
+- $(CXX) $(CCFLAGS) -c $< -o $@
++ $(CXX) $(CXXFLAGS) -fPIC -felide-constructors -c $< -o $@
+
+ OPT = -O
+ DEBUG =
+ CCFLAGS = $(OPT) $(DEBUG)
+ LIBRARY = pdb++
+
+-LIBARCH = lib$(LIBRARY).a
++LIBARCH = lib$(LIBRARY)
+ OBJS = pdb_read.o pdb_sprntf.o pdb_sscanf.o pdb_chars.o \
+ pdb_type.o pdb++.o pdbinput.o
+ SRCS = pdb_read.cc pdb_sprntf.cc pdb_sscanf.cc pdb_chars.cc \
+@@ -30,10 +30,16 @@ all: $(LIBARCH)
+ install: $(LIBARCH)
+ install -F /usr/local/lib $(LIBARCH)
+
+-$(LIBARCH): $(OBJS)
++$(LIBARCH).a: $(OBJS)
+ @echo "Loading $(LIBARCH) ... "
+- @ar cru $(LIBARCH) $(OBJS)
+- @$(RANLIB) $(LIBARCH)
++ $(AR) cru $@ $(OBJS)
++ $(RANLIB) $@
++ @echo "done"
++
++$(LIBARCH).so: $(OBJS)
++ $(CXX) $(LDFLAGS) -shared -Wl,--soname,libpdb++.so.0 -o libpdb++.so.0.1 $(OBJS)
++ ln -sf libpdb++.so.0.1 libpdb++.so.0
++ ln -sf libpdb++.so.0.1 libpdb++.so
+ @echo "done"
+
+ clean:; @rm -f $(OBJS)