summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-19 12:43:22 +0000
committerSam James <sam@gentoo.org>2021-02-19 12:46:14 +0000
commit9b7113f01c54ed5a643f08f2f5649915472e63fb (patch)
treec70a0bd70fdfab498fc8bd6a6e7e58c4382b905c /sci-libs/qrupdate/qrupdate-1.1.2-r1.ebuild
parentsci-chemistry/molden: workaround gcc 10 (fortran) failure (diff)
downloadgentoo-9b7113f01c54ed5a643f08f2f5649915472e63fb.tar.gz
gentoo-9b7113f01c54ed5a643f08f2f5649915472e63fb.tar.bz2
gentoo-9b7113f01c54ed5a643f08f2f5649915472e63fb.zip
sci-libs/qrupdate: workaround gcc 10 (fortran) failure
Closes: https://bugs.gentoo.org/741524 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/qrupdate/qrupdate-1.1.2-r1.ebuild')
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.2-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-libs/qrupdate/qrupdate-1.1.2-r1.ebuild b/sci-libs/qrupdate/qrupdate-1.1.2-r1.ebuild
index 12576510a909..556683f3f338 100644
--- a/sci-libs/qrupdate/qrupdate-1.1.2-r1.ebuild
+++ b/sci-libs/qrupdate/qrupdate-1.1.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils fortran-2 multilib versionator toolchain-funcs
+inherit eutils fortran-2 flag-o-matic multilib versionator toolchain-funcs
DESCRIPTION="Library for updating of QR and Cholesky decompositions"
HOMEPAGE="https://sourceforge.net/projects/qrupdate"
@@ -22,6 +22,11 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PN}-1.1.1-Makefiles.patch \
"${FILESDIR}"/${PN}-1.1.2-install.patch
+
+ # GCC 10 workaround
+ # bug #741524
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
sed -i Makeconf \
-e "s:gfortran:$(tc-getFC):g" \
-e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \