summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-03-30 20:32:59 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-14 19:01:20 +0300
commit25c40796cfe176eac68cf17a1310b58ce8e2ce1d (patch)
tree163faf8a4ce85c80c8e6a99efd9a2b1831314c19 /sci-libs/spr
parentnet-misc/netdate: EAPI8 bump, fix bug #494590, #725204 (diff)
downloadgentoo-25c40796cfe176eac68cf17a1310b58ce8e2ce1d.tar.gz
gentoo-25c40796cfe176eac68cf17a1310b58ce8e2ce1d.tar.bz2
gentoo-25c40796cfe176eac68cf17a1310b58ce8e2ce1d.zip
sci-libs/spr: EAPI8 bump, fix bug #851021
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/851021 Closes: https://github.com/gentoo/gentoo/pull/36002 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-libs/spr')
-rw-r--r--sci-libs/spr/spr-3.3.2-r1.ebuild (renamed from sci-libs/spr/spr-3.3.2.ebuild)13
1 files changed, 10 insertions, 3 deletions
diff --git a/sci-libs/spr/spr-3.3.2.ebuild b/sci-libs/spr/spr-3.3.2-r1.ebuild
index 3b639a0e109b..54935e6924fd 100644
--- a/sci-libs/spr/spr-3.3.2.ebuild
+++ b/sci-libs/spr/spr-3.3.2-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="Statistical analysis and machine learning library"
HOMEPAGE="https://statpatrec.sourceforge.net/"
SRC_URI="mirror://sourceforge/statpatrec/${P^^}.tar.gz"
+S="${WORKDIR}/${P^^}"
LICENSE="GPL-2"
SLOT="0"
@@ -18,7 +19,6 @@ IUSE="root static-libs"
DEPEND="root? ( sci-physics/root )"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P^^}
PATCHES=(
"${FILESDIR}"/${P}-autotools.patch
"${FILESDIR}"/${P}-gcc46.patch
@@ -37,3 +37,10 @@ src_configure() {
$(use_enable static-libs static) \
$(use_with root)
}
+
+src_install() {
+ default
+ if use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}