summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2023-06-04 16:13:26 -0700
committerJason Zaman <perfinion@gentoo.org>2023-06-05 09:37:13 -0700
commit6f665af97a2f0f2e1d29e8c6c157f78e8334e33b (patch)
tree9477a69820a1668c794c9532773b706955d01c92 /sci-libs/tensorflow-estimator
parentsci-libs/keras: add 2.12.0 (diff)
downloadgentoo-6f665af97a2f0f2e1d29e8c6c157f78e8334e33b.tar.gz
gentoo-6f665af97a2f0f2e1d29e8c6c157f78e8334e33b.tar.bz2
gentoo-6f665af97a2f0f2e1d29e8c6c157f78e8334e33b.zip
sci-libs/tensorflow-estimator: add 2.12.0
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/tensorflow-estimator')
-rw-r--r--sci-libs/tensorflow-estimator/Manifest1
-rw-r--r--sci-libs/tensorflow-estimator/tensorflow-estimator-2.12.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-libs/tensorflow-estimator/Manifest b/sci-libs/tensorflow-estimator/Manifest
index c208fabb6300..f908a8805972 100644
--- a/sci-libs/tensorflow-estimator/Manifest
+++ b/sci-libs/tensorflow-estimator/Manifest
@@ -2,3 +2,4 @@ DIST bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip 201360 BLA
DIST bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip 9422 BLAKE2B bbc45c97551ee8126335b611ffca6574dac843d4db9b3221b10d26487f8eecfe38ba0cd67a4039a3ad921c25fea6294c43e4f4e7a57a060a30791acd6c4f9d39 SHA512 ba06242feb711e7fb6e821fd9ac029248b4f3e466fb1acf971d0db8196f3efe4d114ef137acbe4913073f8cbe8ccab4d47d8bafa21b867b2d6a6d57f5a647f0c
DIST tensorflow-estimator-2.10.tar.gz 655011 BLAKE2B 465b405bfc5b776bc9722407f0d475b4ce8a520bded4b6f0db4c9fc771b9486a4ef08ae460f2e1c8c4be1d2882b942fff79f7f08a458eaa444f1bb44eb66e91c SHA512 63cdc97d9abf3551a931372ab91e86b1cab761ea7476182ed82ac7c56884d315107b1873376385bcdfc531465c11fe0273aefe8b88e8b333d8e7b54e7d0a09eb
DIST tensorflow-estimator-2.11.0-rc0.tar.gz 655514 BLAKE2B cc73f282a32f657bf507d948210aa981f0867c4898574c61fb5654204fa573ac7bdef16635d202ed3d202ccc9c8915f5613e4149ce6839d59281a38cfd6953f7 SHA512 c473a6db62a0a55f25f8fd5fd7ffb2f2a473261c5a7b3217bd1d8a21a02ab4871793ea57917c6eb9dc9012bd030faf8030702caf3f764983ce526d201866204f
+DIST tensorflow-estimator-2.12.0.tar.gz 656763 BLAKE2B a67c81487b7765f3195f7567b66455a4be390bff8d6dec751d054a26b654b1aac96982f6fa55d0488a8e6414e7d4b58d1ae59680a1c694615f82718c77478872 SHA512 d86bfde67c97988beeb5abc8042c1847c6d0081d54e21e35424d463895e95a5d0adc74d7d2bb006a617748da3b9a8bbb8979d6a842f024ab3a4d08a2e806147b
diff --git a/sci-libs/tensorflow-estimator/tensorflow-estimator-2.12.0.ebuild b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.12.0.ebuild
new file mode 100644
index 000000000000..fbe71a0d54d6
--- /dev/null
+++ b/sci-libs/tensorflow-estimator/tensorflow-estimator-2.12.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 python3_11 )
+MY_PN="estimator"
+MY_PV=${PV/_rc/-rc}
+MY_P=${MY_PN}-${MY_PV}
+
+inherit bazel distutils-r1
+
+DESCRIPTION="A high-level TensorFlow API that greatly simplifies machine learning programming"
+HOMEPAGE="https://www.tensorflow.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+bazel_external_uris="
+ https://github.com/bazelbuild/rules_cc/archive/b1c40e1de81913a3c40e5948f78719c28152486d.zip -> bazelbuild-rules_cc-b1c40e1de81913a3c40e5948f78719c28152486d.zip
+ https://github.com/bazelbuild/rules_java/archive/7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip -> bazelbuild-rules_java-7cf3cefd652008d0a64a419c34c13bdca6c8f178.zip"
+
+SRC_URI="https://github.com/tensorflow/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz
+ ${bazel_external_uris}"
+
+RDEPEND="
+ sci-libs/tensorflow[python,${PYTHON_USEDEP}]
+ sci-libs/keras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/unzip
+ dev-java/java-config
+ >=dev-util/bazel-5.3.0"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ bazel_load_distfiles "${bazel_external_uris}"
+}
+
+src_prepare() {
+ bazel_setup_bazelrc
+ default
+ python_copy_sources
+}
+
+python_compile() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+
+ ebazel build //tensorflow_estimator/tools/pip_package:build_pip_package
+ ebazel shutdown
+
+ local srcdir="${T}/src-${EPYTHON/./_}"
+ mkdir -p "${srcdir}" || die
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package --src "${srcdir}" || die
+
+ popd >/dev/null || die
+}
+
+src_compile() {
+ export JAVA_HOME=$(java-config --jre-home)
+ distutils-r1_src_compile
+}
+
+python_install() {
+ pushd "${T}/src-${EPYTHON/./_}" >/dev/null || die
+ esetup.py install
+ python_optimize
+ popd >/dev/null || die
+}