summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiezhiko <Miezhiko@gmail.com>2023-06-15 15:42:10 +0400
committerAlfredo Tupone <tupone@gentoo.org>2023-06-15 20:07:14 +0200
commitec59df606b9fc2ca0735a488f23e1f51a4009672 (patch)
treefea6b708dbb1cd489cbd985239867984ebdf76d9 /sci-libs/transformers
parentsci-libs/huggingface_hub: 0.15.1 (diff)
downloadgentoo-ec59df606b9fc2ca0735a488f23e1f51a4009672.tar.gz
gentoo-ec59df606b9fc2ca0735a488f23e1f51a4009672.tar.bz2
gentoo-ec59df606b9fc2ca0735a488f23e1f51a4009672.zip
sci-libs/transformers: 4.30.2
Signed-off-by: Miezhiko <Miezhiko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31453 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs/transformers')
-rw-r--r--sci-libs/transformers/Manifest1
-rw-r--r--sci-libs/transformers/transformers-4.30.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/transformers/Manifest b/sci-libs/transformers/Manifest
index b563df71ecac..4456ae0bf472 100644
--- a/sci-libs/transformers/Manifest
+++ b/sci-libs/transformers/Manifest
@@ -1,2 +1,3 @@
DIST transformers-4.27.4.gh.tar.gz 13210647 BLAKE2B acf5c81ceaaa2f156fc90b2284a6e2d4369742705c14d777c12e94a23961f3ed7cdc8e3cf8a4b962600b59f529862e6546f3d212e1ae1c44b7f76d8a10cbea75 SHA512 8b84a74c473c514314c3c4a422f8c03118575add3499ca280b7259bad72f8f8a6a7a51dc12162963c033b6a65c8914cca011b7bf6343781c5ed35154ea7adaf4
DIST transformers-4.29.2.gh.tar.gz 13775570 BLAKE2B 01d64001e0ca8c06247f35391fe79edd59b3c02e1ec5fe0cac6ca3a4028633f6deba7f50762b2b688acc524658e25b8ecf4b6618ab6ff12d5737fd7c1864ada8 SHA512 2526f9d2de12e3f73899fb6ab5390884f9884a05ba492235bc95897f99bb45616ed737c87b9b8ac83550dd90b68025adf63a1f95c22a2e708528889215c8299c
+DIST transformers-4.30.2.gh.tar.gz 13946731 BLAKE2B 2831f413fb06e4210f59c8b56779a35ba5236ab8934bc955c5997bc45671ca12dbf9fff5997850056876027fa5d542550f8bc00ef86dbd3bc81f65ae0ce964a2 SHA512 dc5d325643a81c275470c15edf98f5863d3ecff3696a376dd369d4f4e9a70ec7d06f23ae8b47354373a8a2f9301543214888cf35b66c9931ac350ab7892ae4c1
diff --git a/sci-libs/transformers/transformers-4.30.2.ebuild b/sci-libs/transformers/transformers-4.30.2.ebuild
new file mode 100644
index 000000000000..944e547fdfbd
--- /dev/null
+++ b/sci-libs/transformers/transformers-4.30.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="State-of-the-art Machine Learning for JAX, PyTorch and TensorFlow"
+HOMEPAGE="
+ https://pypi.org/project/transformers/
+ https://huggingface.co/
+"
+SRC_URI="https://github.com/huggingface/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # Need some modules, not yet packaged
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ sci-libs/huggingface_hub[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sci-libs/tokenizers[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest