summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-31 20:16:45 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-31 23:14:17 -0400
commit12772e77c1002179e87918b5af37ac1d52b64f78 (patch)
tree50d157efe03a1e5525edff8820661709e11c9ce8 /sci-libs
parentsci-libs/ginkgo: remove long-obsolete seds (diff)
downloadgentoo-12772e77c1002179e87918b5af37ac1d52b64f78.tar.gz
gentoo-12772e77c1002179e87918b5af37ac1d52b64f78.tar.bz2
gentoo-12772e77c1002179e87918b5af37ac1d52b64f78.zip
sci-libs/ginkgo: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/862705 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild10
-rw-r--r--sci-libs/ginkgo/ginkgo-1.6.0.ebuild10
-rw-r--r--sci-libs/ginkgo/ginkgo-1.8.0.ebuild10
3 files changed, 27 insertions, 3 deletions
diff --git a/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
index c3849d3ff6dd..0a4e3d5aea71 100644
--- a/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
+++ b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Numerical linear algebra software package"
HOMEPAGE="https://ginkgo-project.github.io/"
@@ -35,6 +35,14 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862705
+ # https://github.com/ginkgo-project/ginkgo/issues/1657
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DGINKGO_DEVEL_TOOLS=OFF
-DGINKGO_BUILD_TESTS=OFF
diff --git a/sci-libs/ginkgo/ginkgo-1.6.0.ebuild b/sci-libs/ginkgo/ginkgo-1.6.0.ebuild
index 3120a68d8975..c08e881a46e3 100644
--- a/sci-libs/ginkgo/ginkgo-1.6.0.ebuild
+++ b/sci-libs/ginkgo/ginkgo-1.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Numerical linear algebra software package"
HOMEPAGE="https://ginkgo-project.github.io/"
@@ -40,6 +40,14 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862705
+ # https://github.com/ginkgo-project/ginkgo/issues/1657
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DGINKGO_DEVEL_TOOLS=OFF
-DGINKGO_BUILD_TESTS=OFF
diff --git a/sci-libs/ginkgo/ginkgo-1.8.0.ebuild b/sci-libs/ginkgo/ginkgo-1.8.0.ebuild
index 9f0450e54c30..028c8cdc3a77 100644
--- a/sci-libs/ginkgo/ginkgo-1.8.0.ebuild
+++ b/sci-libs/ginkgo/ginkgo-1.8.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Numerical linear algebra software package"
HOMEPAGE="https://ginkgo-project.github.io/"
@@ -39,6 +39,14 @@ pkg_setup() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862705
+ # https://github.com/ginkgo-project/ginkgo/issues/1657
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DGINKGO_DEVEL_TOOLS=OFF
-DGINKGO_BUILD_TESTS=OFF