summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-10 15:26:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-10 15:28:33 +0100
commit53c0ed9dd9a4aed4dbe15b5e64e0775a2bd87780 (patch)
treec3716b30e96a99934ec580a3107eabd2533099d9 /sci-libs
parentdev-lang/tk: add 8.6.14 (diff)
downloadgentoo-53c0ed9dd9a4aed4dbe15b5e64e0775a2bd87780.tar.gz
gentoo-53c0ed9dd9a4aed4dbe15b5e64e0775a2bd87780.tar.bz2
gentoo-53c0ed9dd9a4aed4dbe15b5e64e0775a2bd87780.zip
sci-libs/scikit-learn: Fix tests, QA
Deselect failing tests. Clean up the test phase. Use pytest-xdist and disable plugin autoloading for a major speedup. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild27
1 files changed, 22 insertions, 5 deletions
diff --git a/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild b/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
index 63eb9f3b7b75..6639b87b8580 100644
--- a/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
+++ b/sci-libs/scikit-learn/scikit-learn-1.3.2-r1.ebuild
@@ -10,8 +10,15 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Machine learning library for Python"
-HOMEPAGE="https://scikit-learn.org/stable/"
-SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://scikit-learn.org/stable/
+ https://github.com/scikit-learn/scikit-learn/
+ https://pypi.org/project/scikit-learn/
+"
+SRC_URI="
+ https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="BSD"
SLOT="0"
@@ -35,7 +42,9 @@ BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
"
+EPYTEST_XDIST=1
distutils_enable_tests pytest
+
# For some reason this wants to use urllib to fetch things from the internet
# distutils_enable_sphinx doc \
# dev-python/matplotlib \
@@ -49,9 +58,17 @@ distutils_enable_tests pytest
# dev-python/scikit-image
python_test() {
- # This needs to be run in the install dir
- cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
- distutils-r1_python_test
+ local EPYTEST_DESELECT=(
+ # test broken with newer scipy, fixed upstream
+ # https://github.com/scikit-learn/scikit-learn/issues/27578
+ manifold/tests/test_locally_linear.py::test_singular_matrix
+ # TODO
+ gaussian_process/kernels.py::sklearn.gaussian_process.kernels.ExpSineSquared
+ )
+
+ rm -rf sklearn || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs sklearn
}
python_install_all() {